summaryrefslogtreecommitdiff
path: root/dev-vcs/python-gitlab/python-gitlab-1.15.0.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-01-20 21:22:10 +0100
committerKarel Kočí <cynerd@email.cz>2020-01-20 21:22:10 +0100
commit81a8f9a5897d134667d0efd5f4c707b25fe25bfd (patch)
tree8012ba44e4c2e501dbb4825b838ffc077d8d9d75 /dev-vcs/python-gitlab/python-gitlab-1.15.0.ebuild
parent94fa66a515085649ad51ca8ffa9b28973beae1b9 (diff)
downloadgentoo-personal-overlay-81a8f9a5897d134667d0efd5f4c707b25fe25bfd.tar.gz
gentoo-personal-overlay-81a8f9a5897d134667d0efd5f4c707b25fe25bfd.tar.bz2
gentoo-personal-overlay-81a8f9a5897d134667d0efd5f4c707b25fe25bfd.zip
dev-vcs/python-gitlab: update to version 1.15.0
Diffstat (limited to 'dev-vcs/python-gitlab/python-gitlab-1.15.0.ebuild')
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-1.15.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-vcs/python-gitlab/python-gitlab-1.15.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-1.15.0.ebuild
new file mode 100644
index 0000000..e53b651
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-1.15.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7,8} )
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/testrepository[${PYTHON_USEDEP}]
+ dev-python/hacking[${PYTHON_USEDEP}]
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3
+ dev-python/sphinx_rtd_theme )"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}