summaryrefslogtreecommitdiff
path: root/dev-vcs/python-gitlab/python-gitlab-1.13.0.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-12-02 10:31:25 +0100
committerKarel Kočí <cynerd@email.cz>2019-12-02 10:31:25 +0100
commit6dc3c33d523b998204c2104dfb2245d206c4817c (patch)
treeb63b0f4f959cb761cc0868bd18806410cf20c21a /dev-vcs/python-gitlab/python-gitlab-1.13.0.ebuild
parent30a2a03dcf19c32cea9ebcc0c2a332ab57d3f49d (diff)
downloadgentoo-personal-overlay-6dc3c33d523b998204c2104dfb2245d206c4817c.tar.gz
gentoo-personal-overlay-6dc3c33d523b998204c2104dfb2245d206c4817c.tar.bz2
gentoo-personal-overlay-6dc3c33d523b998204c2104dfb2245d206c4817c.zip
dev-vcs/python-gitlab: update to 1.13.0
Diffstat (limited to 'dev-vcs/python-gitlab/python-gitlab-1.13.0.ebuild')
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-1.13.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-vcs/python-gitlab/python-gitlab-1.13.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-1.13.0.ebuild
new file mode 100644
index 0000000..e53b651
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-1.13.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7,8} )
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/testrepository[${PYTHON_USEDEP}]
+ dev-python/hacking[${PYTHON_USEDEP}]
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3
+ dev-python/sphinx_rtd_theme )"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}