summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-05-31 09:51:53 +0200
committerKarel Kočí <cynerd@email.cz>2020-05-31 09:51:53 +0200
commitf0a24546e621c5c609783335b1d2b39fb71d4d91 (patch)
tree5eeb358899300d0be60567eaeea4ccac300d70a7 /dev-util
parentd4e701dcb7ca1fa7f91380e23a9483c923a4904e (diff)
downloadgentoo-personal-overlay-f0a24546e621c5c609783335b1d2b39fb71d4d91.tar.gz
gentoo-personal-overlay-f0a24546e621c5c609783335b1d2b39fb71d4d91.tar.bz2
gentoo-personal-overlay-f0a24546e621c5c609783335b1d2b39fb71d4d91.zip
dev-util/laminar: revert and patch imclude
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/laminar/files/add-missing-includes.patch40
-rw-r--r--dev-util/laminar/laminar-0.8-r5.ebuild (renamed from dev-util/laminar/laminar-0.8-r4.ebuild)12
2 files changed, 46 insertions, 6 deletions
diff --git a/dev-util/laminar/files/add-missing-includes.patch b/dev-util/laminar/files/add-missing-includes.patch
new file mode 100644
index 0000000..546e338
--- /dev/null
+++ b/dev-util/laminar/files/add-missing-includes.patch
@@ -0,0 +1,40 @@
+From 6c61fb311169146eb40c835e1285ac97e43b2082 Mon Sep 17 00:00:00 2001
+From: Oliver Giles <ohw.giles@gmail.com>
+Date: Fri, 22 May 2020 11:42:12 +1200
+Subject: [PATCH] add missing #includes
+
+New compiler version exposed missing header files
+
+resolves #123
+---
+ src/conf.h | 1 +
+ src/server.h | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/src/conf.h b/src/conf.h
+index cdabf95..bc355a7 100644
+--- a/src/conf.h
++++ b/src/conf.h
+@@ -19,6 +19,7 @@
+ #ifndef LAMINAR_CONF_H_
+ #define LAMINAR_CONF_H_
+
++#include <string>
+ #include <unordered_map>
+
+ class StringMap : public std::unordered_map<std::string, std::string> {
+diff --git a/src/server.h b/src/server.h
+index 048f388..e7c0b4f 100644
+--- a/src/server.h
++++ b/src/server.h
+@@ -24,6 +24,7 @@
+ #include <capnp/message.h>
+ #include <capnp/capability.h>
+ #include <functional>
++#include <sys/types.h>
+
+ struct Laminar;
+ struct Http;
+--
+2.26.2
+
diff --git a/dev-util/laminar/laminar-0.8-r4.ebuild b/dev-util/laminar/laminar-0.8-r5.ebuild
index 76a6406..e96686f 100644
--- a/dev-util/laminar/laminar-0.8-r4.ebuild
+++ b/dev-util/laminar/laminar-0.8-r5.ebuild
@@ -2,23 +2,23 @@ EAPI=6
inherit cmake-utils
-HASH="6c61fb311169146eb40c835e1285ac97e43b2082"
DESCRIPTION="Lightweight and modular Continuous Integration service for Linux"
HOMEPAGE="http://laminar.ohwg.net/"
-SRC_URI="https://github.com/ohwgiles/${PN}/archive/${HASH}.tar.gz -> ${PN}-${HASH}.tar.gz
+SRC_URI="https://github.com/ohwgiles/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
https://cdnjs.cloudflare.com/ajax/libs/vue/2.3.4/vue.min.js -> ${PN}-vue.min.js
https://cdnjs.cloudflare.com/ajax/libs/vue-router/2.7.0/vue-router.min.js -> ${PN}-vue-router.min.js
https://raw.githubusercontent.com/drudru/ansi_up/v1.3.0/ansi_up.js -> ${PN}-ansi_up.js
https://cdnjs.cloudflare.com/ajax/libs/Chart.js/2.7.2/Chart.min.js -> ${PN}-Chart.min.js
https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/css/bootstrap.min.css -> ${PN}-bootstrap.min.css"
+PATCHES=(
+ "${FILESDIR}/add-missing-includes.patch"
+)
LICENSE=""
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-S="${WORKDIR}/laminar-${HASH}"
-
DEPEND="
dev-libs/capnproto
dev-libs/rapidjson
@@ -31,11 +31,11 @@ RDEPEND="${DEPEND}
src_unpack() {
# Note that ${A} contains also other files so no general unpack
- unpack "${PN}-${HASH}.tar.gz"
+ unpack "${P}.tar.gz"
}
# Note: lamianr build system in default downloads external files but that is not
-# possible for some reason in sandbox. This downloads those files outside of
+# possible in sandbox because of . This downloads those files outside of
# scripts and copies them to correct place before configure which prevents from
# download happening/failing.
src_configure() {