summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2020-02-04 10:14:12 +0100
committerKarel Kočí <karel.koci@nic.cz>2020-02-04 10:14:12 +0100
commit1a9f96c2c7cf1e83b67552e57773de85233d56e2 (patch)
treef8ed3b1fd88e5870dd1f8e7dec070a8664176a77 /dev-util
parent391a8473ea60f7c8aa293aac232da53a7c5c836d (diff)
downloadgentoo-personal-overlay-1a9f96c2c7cf1e83b67552e57773de85233d56e2.tar.gz
gentoo-personal-overlay-1a9f96c2c7cf1e83b67552e57773de85233d56e2.tar.bz2
gentoo-personal-overlay-1a9f96c2c7cf1e83b67552e57773de85233d56e2.zip
dev-util/uncrustify: update to latest version
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/uncrustify/uncrustify-0.70.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/uncrustify/uncrustify-0.70.1.ebuild b/dev-util/uncrustify/uncrustify-0.70.1.ebuild
new file mode 100644
index 0000000..85a400d
--- /dev/null
+++ b/dev-util/uncrustify/uncrustify-0.70.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ $PV == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ scm_eclass=git-r3
+else
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+ S=${WORKDIR}/${PN}-${P}
+fi
+
+inherit cmake-utils ${scm_eclass}
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1
+
+DESCRIPTION="C/C++/C#/D/Java/Pawn code indenter and beautifier"
+HOMEPAGE="http://uncrustify.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+python_test() {
+ cd tests
+ ${EPYTHON} run_tests.py || die "tests failed"
+}