summaryrefslogtreecommitdiff
path: root/dev-util/laminar/laminar-0.8-r2.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2020-03-12 15:48:48 +0100
committerKarel Kočí <karel.koci@nic.cz>2020-03-12 15:48:48 +0100
commit4c05515c2ea6ad965754801eff632b6e3d37c4fb (patch)
tree10008ebb4fa4ab940d05739000d035cb6c9a3975 /dev-util/laminar/laminar-0.8-r2.ebuild
parent4df656f03cbb191108eed869ecea6566368e288f (diff)
downloadgentoo-personal-overlay-4c05515c2ea6ad965754801eff632b6e3d37c4fb.tar.gz
gentoo-personal-overlay-4c05515c2ea6ad965754801eff632b6e3d37c4fb.tar.bz2
gentoo-personal-overlay-4c05515c2ea6ad965754801eff632b6e3d37c4fb.zip
dev-utils/laminar: supervise this daemon
Diffstat (limited to 'dev-util/laminar/laminar-0.8-r2.ebuild')
-rw-r--r--dev-util/laminar/laminar-0.8-r2.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-util/laminar/laminar-0.8-r2.ebuild b/dev-util/laminar/laminar-0.8-r2.ebuild
deleted file mode 100644
index 479ed3b..0000000
--- a/dev-util/laminar/laminar-0.8-r2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Lightweight and modular Continuous Integration service for Linux"
-HOMEPAGE="http://laminar.ohwg.net/"
-SRC_URI="https://github.com/ohwgiles/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
- https://cdnjs.cloudflare.com/ajax/libs/vue/2.3.4/vue.min.js -> ${P}-vue.min.js
- https://cdnjs.cloudflare.com/ajax/libs/vue-router/2.7.0/vue-router.min.js -> ${P}-vue-router.min.js
- https://raw.githubusercontent.com/drudru/ansi_up/v1.3.0/ansi_up.js -> ${P}-ansi_up.js
- https://cdnjs.cloudflare.com/ajax/libs/Chart.js/2.7.2/Chart.min.js -> ${P}-Chart.min.js
- https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/css/bootstrap.min.css -> ${P}-bootstrap.min.css"
-
-LICENSE=""
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- dev-libs/capnproto
- dev-libs/rapidjson
- dev-db/sqlite
- dev-libs/boost
-"
-RDEPEND="${DEPEND}
- acct-user/build
-"
-
-src_unpack() {
- # Note that ${A} contains also other files so no general unpack
- unpack "${P}.tar.gz"
-}
-
-# Note: lamianr build system in default downloads external files but that is not
-# possible for some reason in sandbox. This downloads those files outside of
-# scripts and copies them to correct place before configure which prevents from
-# download happening/failing.
-src_configure() {
- local BUILD_DIR="${WORKDIR}/${P}_build"
- mkdir -p ${BUILD_DIR}/js
- for file in vue.min.js vue-router.min.js ansi_up.js Chart.min.js; do
- cat "${DISTDIR}/${P}-${file}" > "${BUILD_DIR}/js/${file}"
- done
- mkdir -p ${BUILD_DIR}/css
- for file in bootstrap.min.css; do
- cat "${DISTDIR}/${P}-${file}" > "${BUILD_DIR}/css/${file}"
- done
-
- local mycmakeargs=(
- "-DCMAKE_INSTALL_PREFIX=/"
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- newinitd "${FILESDIR}/laminar.init" laminar
-}