summaryrefslogtreecommitdiff
path: root/dev-util/laminar/laminar-0.6.0.4.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-10-17 13:03:24 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-10-17 13:03:24 +0200
commit82029c2d76673c0b57609b6ea911652b3cabe5af (patch)
treeba36edd5f13c04669d771bd9de570e804c261a55 /dev-util/laminar/laminar-0.6.0.4.ebuild
parent963fb455a23fd737e64002f6b81dc217c8b3ee79 (diff)
downloadgentoo-personal-overlay-82029c2d76673c0b57609b6ea911652b3cabe5af.tar.gz
gentoo-personal-overlay-82029c2d76673c0b57609b6ea911652b3cabe5af.tar.bz2
gentoo-personal-overlay-82029c2d76673c0b57609b6ea911652b3cabe5af.zip
dev-util/laminar: update to latest git master
Diffstat (limited to 'dev-util/laminar/laminar-0.6.0.4.ebuild')
-rw-r--r--dev-util/laminar/laminar-0.6.0.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/laminar/laminar-0.6.0.4.ebuild b/dev-util/laminar/laminar-0.6.0.4.ebuild
new file mode 100644
index 0000000..bff8169
--- /dev/null
+++ b/dev-util/laminar/laminar-0.6.0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+HASHV="cc7d9fa4dabffdbfa5224cc1e667bc96cfa8ee5e"
+DESCRIPTION="Lightweight and modular Continuous Integration service for Linux"
+HOMEPAGE="http://laminar.ohwg.net/"
+SRC_URI="https://github.com/ohwgiles/${PN}/archive/${HASHV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/capnproto
+ dev-libs/rapidjson
+ dev-db/sqlite
+ dev-libs/boost"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/laminar-${HASHV}"
+
+MYCMAKEARGS="-DCMAKE_INSTALL_PREFIX=/"