summaryrefslogtreecommitdiff
path: root/dev-util/laminar/laminar-0.6.0.2.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-10-14 16:23:50 +0200
committerKarel Kočí <cynerd@email.cz>2018-10-14 16:23:50 +0200
commit7a22ad2aac7ead239aec72e800480da742f747b2 (patch)
tree1f4e85823cfae038e9324aeb96cdc0db062c18f4 /dev-util/laminar/laminar-0.6.0.2.ebuild
parent79fee8daa7d6ce0afc7a0abad83ff450a77edf0e (diff)
downloadgentoo-personal-overlay-7a22ad2aac7ead239aec72e800480da742f747b2.tar.gz
gentoo-personal-overlay-7a22ad2aac7ead239aec72e800480da742f747b2.tar.bz2
gentoo-personal-overlay-7a22ad2aac7ead239aec72e800480da742f747b2.zip
dev-utils/laminar: update to unstable version with list commands
Diffstat (limited to 'dev-util/laminar/laminar-0.6.0.2.ebuild')
-rw-r--r--dev-util/laminar/laminar-0.6.0.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/laminar/laminar-0.6.0.2.ebuild b/dev-util/laminar/laminar-0.6.0.2.ebuild
new file mode 100644
index 0000000..f5a3585
--- /dev/null
+++ b/dev-util/laminar/laminar-0.6.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+HASHV="7cee824cee4f32c484b5489728fd91a1523d1b27"
+DESCRIPTION="Lightweight and modular Continuous Integration service for Linux"
+HOMEPAGE="http://laminar.ohwg.net/"
+SRC_URI="https://github.com/ohwgiles/${PN}/archive/${HASHV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/capnproto
+ dev-libs/rapidjson
+ dev-db/sqlite
+ dev-libs/boost"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/laminar-${HASHV}"
+
+MYCMAKEARGS="-DCMAKE_INSTALL_PREFIX=/"