summaryrefslogtreecommitdiff
path: root/dev-util/ccls/ccls-0.20201219.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-12-28 19:59:44 +0100
committerKarel Kočí <cynerd@email.cz>2020-12-28 19:59:44 +0100
commit57a36719fb445a57807e2d239de12fd0e936064d (patch)
treefc36d8527594a30e9d6acf535329de6e11a800e8 /dev-util/ccls/ccls-0.20201219.ebuild
parent0b3b14a3a89d2b2cbfe5b8f2b6d83fc5ec974136 (diff)
downloadgentoo-personal-overlay-57a36719fb445a57807e2d239de12fd0e936064d.tar.gz
gentoo-personal-overlay-57a36719fb445a57807e2d239de12fd0e936064d.tar.bz2
gentoo-personal-overlay-57a36719fb445a57807e2d239de12fd0e936064d.zip
dev-util/ccls: update to version 20201219
Diffstat (limited to 'dev-util/ccls/ccls-0.20201219.ebuild')
-rw-r--r--dev-util/ccls/ccls-0.20201219.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/ccls/ccls-0.20201219.ebuild b/dev-util/ccls/ccls-0.20201219.ebuild
new file mode 100644
index 0000000..3e2baf8
--- /dev/null
+++ b/dev-util/ccls/ccls-0.20201219.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils llvm
+
+DESCRIPTION="C/C++/Objective-C language server"
+HOMEPAGE="https://github.com/MaskRay/ccls"
+SRC_URI="https://github.com/MaskRay/ccls/archive/${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-util/cmake-3.8"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_PREFIX_PATH="$(get_llvm_prefix)"
+ )
+ cmake-utils_src_configure
+}