summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-02-14 16:37:19 +0100
committerKarel Kočí <karel.koci@nic.cz>2018-02-14 16:37:19 +0100
commitf8b1be002c01000356c2aa4f626dd3fbd122e0d5 (patch)
treefab254b7ca124b33e18148bb2fc5f1a9cd8afb22 /dev-qt
parent2d71427ea88d6162799f0b2d464d4bdd255010e0 (diff)
downloadgentoo-personal-overlay-f8b1be002c01000356c2aa4f626dd3fbd122e0d5.tar.gz
gentoo-personal-overlay-f8b1be002c01000356c2aa4f626dd3fbd122e0d5.tar.bz2
gentoo-personal-overlay-f8b1be002c01000356c2aa4f626dd3fbd122e0d5.zip
Ups revert qtstyleplugin revert
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtstyleplugin/qtstyleplugin-171103.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-qt/qtstyleplugin/qtstyleplugin-171103.ebuild b/dev-qt/qtstyleplugin/qtstyleplugin-171103.ebuild
new file mode 100644
index 0000000..f897b0d
--- /dev/null
+++ b/dev-qt/qtstyleplugin/qtstyleplugin-171103.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils git-r3
+
+DESCRIPTION="Additional style plugins for Qt5 (gtk2, cleanlook, plastic, motif)"
+HOMEPAGE="https://code.qt.io/cgit/qt/qtstyleplugins.git/"
+EGIT_REPO_URI="https://code.qt.io/qt/qtstyleplugins.git"
+EGIT_COMMIT="335dbece103e2cbf6c7cf819ab6672c2956b17b3"
+
+LICENSE="LGPL-2"
+SLOT="5"
+KEYWORDS="x86 amd64"
+
+DEPEND="
+ x11-libs/gtk+:2
+ dev-qt/qtgui:5
+ dev-qt/qtdbus:5
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ elog ""
+ elog "To make Qt5 applications use the gtk2 style"
+ elog "insert the following into ~/.profile:"
+ elog "QT_QPA_PLATFORMTHEME=gtk2"
+ elog "For environments using ~/.pam_environment (gnome wayland):"
+ elog "QT_QPA_PLATFORMTHEME OVERRIDE=gtk2"
+ elog ""
+}