summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-12-18 21:55:10 +0100
committerKarel Kočí <cynerd@email.cz>2017-12-18 21:55:10 +0100
commit64656974441390ca8edb90fcdd4e9f328c72e7bf (patch)
tree7f6ade6b381e6f935ab1fd3fb3ad633c30fe2129 /dev-qt
parentc48f8da58ef2c7912e19914880e756ae89c71915 (diff)
downloadgentoo-personal-overlay-64656974441390ca8edb90fcdd4e9f328c72e7bf.tar.gz
gentoo-personal-overlay-64656974441390ca8edb90fcdd4e9f328c72e7bf.tar.bz2
gentoo-personal-overlay-64656974441390ca8edb90fcdd4e9f328c72e7bf.zip
Add qtstyleplugin
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtstyleplugin/qtstyleplugin-5.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-qt/qtstyleplugin/qtstyleplugin-5.0.ebuild b/dev-qt/qtstyleplugin/qtstyleplugin-5.0.ebuild
new file mode 100644
index 0000000..2e80174
--- /dev/null
+++ b/dev-qt/qtstyleplugin/qtstyleplugin-5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils git-r3
+
+DESCRIPTION="Additional style plugins for Qt5 (gtk2, cleanlook, plastic, motif)"
+HOMEPAGE="https://code.qt.io/cgit/qt/qtstyleplugins.git/"
+EGIT_REPO_URI="https://code.qt.io/qt/qtstyleplugins.git"
+EGIT_COMMIT="v${PV}"
+
+LICENSE="LGPL-2"
+SLOT="5"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="
+ x11-libs/gtk+:2
+ dev-qt/qtgui:5
+ dev-qt/qtdbus:5
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ elog ""
+ elog "To make Qt5 applications use the gtk2 style"
+ elog "insert the following into ~/.profile:"
+ elog "QT_QPA_PLATFORMTHEME=gtk2"
+ elog "For environments using ~/.pam_environment (gnome wayland):"
+ elog "QT_QPA_PLATFORMTHEME OVERRIDE=gtk2"
+ elog ""
+}