summaryrefslogtreecommitdiff
path: root/dev-qt/qtstyleplugin/qtstyleplugin-5.0.0.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-12-18 22:00:44 +0100
committerKarel Kočí <cynerd@email.cz>2017-12-18 22:00:44 +0100
commit9cdd0eb83f33c1b5d6fd04a500305bb1884cb177 (patch)
treedacd9495b7b43ac7fe00ed7392f6909c14788f2e /dev-qt/qtstyleplugin/qtstyleplugin-5.0.0.ebuild
parentf62c6f025dc22a4b701bb5b93f4c25eee24bce61 (diff)
downloadgentoo-personal-overlay-9cdd0eb83f33c1b5d6fd04a500305bb1884cb177.tar.gz
gentoo-personal-overlay-9cdd0eb83f33c1b5d6fd04a500305bb1884cb177.tar.bz2
gentoo-personal-overlay-9cdd0eb83f33c1b5d6fd04a500305bb1884cb177.zip
Fix qtstyleplugin version
Diffstat (limited to 'dev-qt/qtstyleplugin/qtstyleplugin-5.0.0.ebuild')
-rw-r--r--dev-qt/qtstyleplugin/qtstyleplugin-5.0.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-qt/qtstyleplugin/qtstyleplugin-5.0.0.ebuild b/dev-qt/qtstyleplugin/qtstyleplugin-5.0.0.ebuild
new file mode 100644
index 0000000..65ddfd6
--- /dev/null
+++ b/dev-qt/qtstyleplugin/qtstyleplugin-5.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils git-r3
+
+DESCRIPTION="Additional style plugins for Qt5 (gtk2, cleanlook, plastic, motif)"
+HOMEPAGE="https://code.qt.io/cgit/qt/qtstyleplugins.git/"
+EGIT_REPO_URI="https://code.qt.io/qt/qtstyleplugins.git"
+EGIT_COMMIT="v${PV}"
+
+LICENSE="LGPL-2"
+SLOT="5"
+KEYWORDS="x86 amd64"
+
+DEPEND="
+ x11-libs/gtk+:2
+ dev-qt/qtgui:5
+ dev-qt/qtdbus:5
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ elog ""
+ elog "To make Qt5 applications use the gtk2 style"
+ elog "insert the following into ~/.profile:"
+ elog "QT_QPA_PLATFORMTHEME=gtk2"
+ elog "For environments using ~/.pam_environment (gnome wayland):"
+ elog "QT_QPA_PLATFORMTHEME OVERRIDE=gtk2"
+ elog ""
+}