summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2021-07-20 23:10:05 +0200
committerKarel Kočí <cynerd@email.cz>2021-07-20 23:10:05 +0200
commitf5235b713dedb5d7a77e67f9506c7a280aa9bb47 (patch)
tree37931968c16ef8ad1523a55cc0e4812415cdc3fe /dev-python
parent0fb4db8f2431a29654cf011d484bdf8e5fdc0352 (diff)
downloadgentoo-personal-overlay-f5235b713dedb5d7a77e67f9506c7a280aa9bb47.tar.gz
gentoo-personal-overlay-f5235b713dedb5d7a77e67f9506c7a280aa9bb47.tar.bz2
gentoo-personal-overlay-f5235b713dedb5d7a77e67f9506c7a280aa9bb47.zip
dev-python: expand various targets for new versions
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/daemonocle/daemonocle-1.2.2.ebuild2
-rw-r--r--dev-python/feedgen/feedgen-0.9.0.ebuild2
-rw-r--r--dev-python/jsonrpc-server/jsonrpc-server-0.4.0-r3.ebuild2
-rw-r--r--dev-python/pylxd/pylxd-2.3.0.ebuild2
-rw-r--r--dev-python/schema/schema-0.7.4-r2.ebuild6
5 files changed, 6 insertions, 8 deletions
diff --git a/dev-python/daemonocle/daemonocle-1.2.2.ebuild b/dev-python/daemonocle/daemonocle-1.2.2.ebuild
index c7260c5..6ec96d6 100644
--- a/dev-python/daemonocle/daemonocle-1.2.2.ebuild
+++ b/dev-python/daemonocle/daemonocle-1.2.2.ebuild
@@ -1,6 +1,6 @@
EAPI="6"
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Library for creating your own Unix-style daemons"
diff --git a/dev-python/feedgen/feedgen-0.9.0.ebuild b/dev-python/feedgen/feedgen-0.9.0.ebuild
index 32b8c7e..445210e 100644
--- a/dev-python/feedgen/feedgen-0.9.0.ebuild
+++ b/dev-python/feedgen/feedgen-0.9.0.ebuild
@@ -1,5 +1,5 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
diff --git a/dev-python/jsonrpc-server/jsonrpc-server-0.4.0-r3.ebuild b/dev-python/jsonrpc-server/jsonrpc-server-0.4.0-r3.ebuild
index f190d89..558b634 100644
--- a/dev-python/jsonrpc-server/jsonrpc-server-0.4.0-r3.ebuild
+++ b/dev-python/jsonrpc-server/jsonrpc-server-0.4.0-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Python JSON RPC Server"
diff --git a/dev-python/pylxd/pylxd-2.3.0.ebuild b/dev-python/pylxd/pylxd-2.3.0.ebuild
index ed192f3..99e068c 100644
--- a/dev-python/pylxd/pylxd-2.3.0.ebuild
+++ b/dev-python/pylxd/pylxd-2.3.0.ebuild
@@ -1,5 +1,5 @@
EAPI=7
-PYTHON_COMPAT=( python3_{5,6,7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
diff --git a/dev-python/schema/schema-0.7.4-r2.ebuild b/dev-python/schema/schema-0.7.4-r2.ebuild
index ad51dde..0413688 100644
--- a/dev-python/schema/schema-0.7.4-r2.ebuild
+++ b/dev-python/schema/schema-0.7.4-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
@@ -18,6 +18,4 @@ SLOT="0"
LICENSE="MIT"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/contextlib2-0.5.5[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"