summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-07-22 12:38:18 +0200
committerKarel Kočí <cynerd@email.cz>2018-07-22 12:38:18 +0200
commitf2144bf875839771884c008d704234b2a0cc2e03 (patch)
treeddf0882e79a1a7fcf6f92dec00de861de90d24c9 /dev-python
parent7990c6c5454dee41ca7692e71b2d544d043178a8 (diff)
downloadgentoo-personal-overlay-f2144bf875839771884c008d704234b2a0cc2e03.tar.gz
gentoo-personal-overlay-f2144bf875839771884c008d704234b2a0cc2e03.tar.bz2
gentoo-personal-overlay-f2144bf875839771884c008d704234b2a0cc2e03.zip
Add testing package python3-prctl
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python3-prctl/python3-prctl-1.6.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python3-prctl/python3-prctl-1.6.1.ebuild b/dev-python/python3-prctl/python3-prctl-1.6.1.ebuild
new file mode 100644
index 0000000..81dfbf2
--- /dev/null
+++ b/dev-python/python3-prctl/python3-prctl-1.6.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Control process attributes through prctl"
+HOMEPAGE="https://github.com/seveas/python-prctl"
+SRC_URI="https://github.com/seveas/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/libcap"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}