summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-01-04 16:48:56 +0100
committerKarel Kočí <cynerd@email.cz>2019-01-04 16:48:56 +0100
commitcb6a984979882f8f892fe1b4040583aa80d6fb77 (patch)
treeb342e8e7135d777495d1b49d0a890d36d49bbb33 /dev-python
parentbddb2ee1a2676b40d38c0e36fe1afe0453ebffc0 (diff)
downloadgentoo-personal-overlay-cb6a984979882f8f892fe1b4040583aa80d6fb77.tar.gz
gentoo-personal-overlay-cb6a984979882f8f892fe1b4040583aa80d6fb77.tar.bz2
gentoo-personal-overlay-cb6a984979882f8f892fe1b4040583aa80d6fb77.zip
Drop icalendar
Changes are now in upstream.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/icalendar/Manifest1
-rw-r--r--dev-python/icalendar/icalendar-4.0.3-r1.ebuild48
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/icalendar/Manifest b/dev-python/icalendar/Manifest
deleted file mode 100644
index 5638437..0000000
--- a/dev-python/icalendar/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST icalendar-4.0.3.tar.gz 77899 BLAKE2B d4043914b85359a8309dd7c8acce55ec5921508319342f2ffb2e16017aa5aa164ef7fdd44aee7820a971516a3e157b5c8ee86732e669c8eac4b5c4bc1767e334 SHA512 2f0ac5a7f36c7d37047ba20bec3f2ca7df51a9e3ec3f29751c71cdd264c01f7e0abd6efc298dac5a7c87911cb4916e56bf77716d6ca05a2d090e26486e6a56be
diff --git a/dev-python/icalendar/icalendar-4.0.3-r1.ebuild b/dev-python/icalendar/icalendar-4.0.3-r1.ebuild
deleted file mode 100644
index f903290..0000000
--- a/dev-python/icalendar/icalendar-4.0.3-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
-HOMEPAGE="https://github.com/collective/icalendar"
-SRC_URI="mirror://pypi/i/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE="doc test"
-DOCS="README.rst"
-
-RDEPEND="
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-DEPEND="
- ${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # reset conf.py to not read version from an installed instance
- sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
- -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- emake -C docs text
- DOCS=( ${DOCS} docs/_build/text/*.txt )
- fi
-}
-
-python_test() {
- # From tox.ini
- coverage run --source=src/icalendar --omit=*/tests/* --module \
- pytest src/icalendar || die "test failed under ${EPYTHON}"
-}