summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-04-18 00:12:06 +0200
committerKarel Kočí <cynerd@email.cz>2020-04-18 00:12:06 +0200
commitc7ba9acb0160353a271374126291a0f7513b4849 (patch)
tree5699e015ba254c94c9f055eeb36e8e938afbe3ac /dev-python
parent426901bf185d6f3a8ac44330fc05193ae9b36657 (diff)
downloadgentoo-personal-overlay-c7ba9acb0160353a271374126291a0f7513b4849.tar.gz
gentoo-personal-overlay-c7ba9acb0160353a271374126291a0f7513b4849.tar.bz2
gentoo-personal-overlay-c7ba9acb0160353a271374126291a0f7513b4849.zip
dev-python/vdirsyncer: enable new python versions
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/vdirsyncer/Manifest1
-rw-r--r--dev-python/vdirsyncer/vdirsyncer-0.16.7.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/vdirsyncer/Manifest b/dev-python/vdirsyncer/Manifest
new file mode 100644
index 0000000..b57a46d
--- /dev/null
+++ b/dev-python/vdirsyncer/Manifest
@@ -0,0 +1 @@
+DIST vdirsyncer-0.16.7.tar.gz 112786 BLAKE2B 19b9ce6e3e9de0a626b9562b4d54b270c1532d93169fe2d872f15c6bf6e1ac94bc623c171e51e871082422116636b4945b58dd172cfca527a010906737f1b6a3 SHA512 218c6781139a9e979077308dc732756cc27ecb67966e4b52be31cb1ebf04d224443036102d5c4bad253b9dcf533939f0b72082166f0fe94e042a7e946b8fad0e
diff --git a/dev-python/vdirsyncer/vdirsyncer-0.16.7.ebuild b/dev-python/vdirsyncer/vdirsyncer-0.16.7.ebuild
new file mode 100644
index 0000000..358b2b3
--- /dev/null
+++ b/dev-python/vdirsyncer/vdirsyncer-0.16.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Synchronize calendars and contacts"
+HOMEPAGE="https://github.com/pimutils/vdirsyncer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/click-log-0.3.0[${PYTHON_USEDEP}]
+ <dev-python/click-log-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/click-threading-0.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.1[${PYTHON_USEDEP}]
+ !=dev-python/requests-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/atomicwrites-0.1.7[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-3.1[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pytest-subtesthack[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst CONTRIBUTING.rst README.rst config.example )
+
+python_test() {
+ # skip tests needing servers running
+ local -x DAV_SERVER=skip
+ local -x REMOTESTORAGE_SERVER=skip
+ # pytest dies hard if the envvars do not have any value...
+ local -x CI=false
+ local -x DETERMINISTIC_TESTS=false
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}