summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-06-29 17:21:39 +0200
committerKarel Kočí <cynerd@email.cz>2020-06-29 17:21:39 +0200
commit743fd9978173cdbe134b80d1b57689caf587a0a7 (patch)
tree7544a5756774548022dc084f45136f81b4782159 /dev-python
parent4f03f9f6119256f33089ead880fc3431b72374bd (diff)
downloadgentoo-personal-overlay-743fd9978173cdbe134b80d1b57689caf587a0a7.tar.gz
gentoo-personal-overlay-743fd9978173cdbe134b80d1b57689caf587a0a7.tar.bz2
gentoo-personal-overlay-743fd9978173cdbe134b80d1b57689caf587a0a7.zip
dev-python/ws4py: remove as this version is now in upstream
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ws4py/Manifest1
-rw-r--r--dev-python/ws4py/ws4py-0.5.1.ebuild50
2 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/ws4py/Manifest b/dev-python/ws4py/Manifest
deleted file mode 100644
index 7f62255..0000000
--- a/dev-python/ws4py/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST ws4py-0.5.1.tar.gz 116673 BLAKE2B 31db304800f0d3da61dc4c1a3381a8fcfcfa8f16b36d916311cc32f1d294c9f7b3627dac673edf824f529f485f825ca418ab1e1a8a2fda5583c6a6a1bd9b752c SHA512 4c90d66d37fb5bdc8f7fc9fd184b20a7dc2dae811ecf3a041477e3c26a2577008be7041799daca5b8c0de65cb2454022a6c135cf02534ca98b6946abbfce0e11
diff --git a/dev-python/ws4py/ws4py-0.5.1.ebuild b/dev-python/ws4py/ws4py-0.5.1.ebuild
deleted file mode 100644
index 4876ed4..0000000
--- a/dev-python/ws4py/ws4py-0.5.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# We could depend on dev-python/cherrypy when USE=server, but
-# that is an optional component ...
-# Same for www-servers/tornado and USE=client ... so why not???
-# pypy is viable but better with a cutdown set of deps
-
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/Lawouach/WebSocket-for-Python.git"
- inherit git-r3
-else
- inherit vcs-snapshot
- SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm x86"
-fi
-
-DESCRIPTION="WebSocket client and server library for Python 2 and 3 as well as PyPy"
-HOMEPAGE="https://github.com/Lawouach/WebSocket-for-Python"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="+client +server test +threads"
-RESTRICT="!test? ( test )"
-# doc build requires sphinxcontrib ext packages absent from portage
-
-RDEPEND=">=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
- >=dev-python/cython-0.19.1[${PYTHON_USEDEP}]
- client? ( >=www-servers/tornado-3.1[${PYTHON_USEDEP}] )
- server? ( >=dev-python/cherrypy-3.2.4[${PYTHON_USEDEP}] )"
-DEPEND="test? (
- >=dev-python/cherrypy-3.2.4[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- # testsuite displays an issue with mock under py3 but is non fatal
- "${PYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install
- use client || rm -rf "${D}$(python_get_sitedir)"/ws4py/client
- use server || rm -rf "${D}$(python_get_sitedir)"/ws4py/server
-}