summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2020-06-30 13:43:50 +0200
committerKarel Kočí <karel.koci@nic.cz>2020-06-30 13:43:50 +0200
commit30d50370a8bf085cd690d476bf56721a86aa5704 (patch)
tree58c5d3ba3da0fae0021fe4d3058d1b9728bf7c10 /dev-python
parent89a7e12616281a721dca5f0945b7151785d5d8be (diff)
downloadgentoo-personal-overlay-30d50370a8bf085cd690d476bf56721a86aa5704.tar.gz
gentoo-personal-overlay-30d50370a8bf085cd690d476bf56721a86aa5704.tar.bz2
gentoo-personal-overlay-30d50370a8bf085cd690d476bf56721a86aa5704.zip
dev-python/jedi: remove as it is now in upstream
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jedi/Manifest1
-rw-r--r--dev-python/jedi/jedi-0.17.1.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/jedi/Manifest b/dev-python/jedi/Manifest
deleted file mode 100644
index 6fe1723..0000000
--- a/dev-python/jedi/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST jedi-0.17.1.tar.gz 472489 BLAKE2B 7486925cb307f6a25538c2f5d52763802222561cfc4beca1637e433f4450b06ef328204e75779b6b2ac4ca2cfcf5ab647daecd329941ca6fb0ae2a5dd2bd8b5f SHA512 0a9d552d2b4c45730c9cccf06ebb434b159b755acea0dbaddf5f628dccf8e9c752e03d151258e377b817f1a25fb9ca8e0289dbd2da290f55dc719883413b65cf
diff --git a/dev-python/jedi/jedi-0.17.1.ebuild b/dev-python/jedi/jedi-0.17.1.ebuild
deleted file mode 100644
index d99e815..0000000
--- a/dev-python/jedi/jedi-0.17.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Autocompletion library for Python"
-HOMEPAGE="https://github.com/davidhalter/jedi"
-SRC_URI="https://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/parso-0.5.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx )
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- ${RDEPEND}
- )"
-
-python_prepare_all() {
- # speed tests are fragile
- rm test/test_speed.py || die
-
- # 'path' completion test does not account for 'path' being a valid
- # package (i.e. dev-python/path-py)
- # https://github.com/davidhalter/jedi/issues/1210
- sed -i -e '/path.*not in/d' test/test_evaluate/test_imports.py || die
-
- # no clue why it fails but we don't really care about .pyc files
- # without sources anyway
- rm test/test_evaluate/test_pyc.py || die
-
- # our very useful patching changes libdir for no good reason
- sed -i -e "/site_pkg_path/s:'lib':& if virtualenv.version_info >= (3,7) else '$(get_libdir)':" \
- test/test_evaluate/test_sys_path.py || die
-
- # this super-secret feature of py3.4 apparently doesn't work for us
- sed -i -e 's:test_init_extension_module:_&:' \
- test/test_evaluate/test_extension.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -vv jedi test || die "Tests failed under ${EPYTHON}"
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( "${S}"/docs/_build/html/. )
- distutils-r1_python_install_all
-}