summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-06-29 17:14:22 +0200
committerKarel Kočí <cynerd@email.cz>2020-06-29 17:14:22 +0200
commit0cf272806dd653e8ed39bb88f94e16e628038cc7 (patch)
tree4e0a0d2938ff6b2a3612b1dd0a9cfccc951ebab9 /dev-python
parent68be1b6ff60805009ed0fabf5f059ebeb314d152 (diff)
downloadgentoo-personal-overlay-0cf272806dd653e8ed39bb88f94e16e628038cc7.tar.gz
gentoo-personal-overlay-0cf272806dd653e8ed39bb88f94e16e628038cc7.tar.bz2
gentoo-personal-overlay-0cf272806dd653e8ed39bb88f94e16e628038cc7.zip
dev-python/jedi: update to versiuon 0.17.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jedi/Manifest3
-rw-r--r--dev-python/jedi/jedi-0.15.1.ebuild62
-rw-r--r--dev-python/jedi/jedi-0.17.1.ebuild (renamed from dev-python/jedi/jedi-0.14.1.ebuild)0
3 files changed, 1 insertions, 64 deletions
diff --git a/dev-python/jedi/Manifest b/dev-python/jedi/Manifest
index 5b34824..6fe1723 100644
--- a/dev-python/jedi/Manifest
+++ b/dev-python/jedi/Manifest
@@ -1,2 +1 @@
-DIST jedi-0.14.1.tar.gz 860206 BLAKE2B d1234ceb417f531c5a29908843a47bec5b198abbc848248517f2796d95319e2d930f7c01af9759cb9a3d44a28fb73c4080802642aea1be32f16689e76c1a49ce SHA512 d68c350259921792788917440c9dd6eb923c90eb1b8d0e078a6d428fad852c4d6bbdc74d8caa88ba5a87db344e4b372dc9cfc959d7bab922888d70402fcf4776
-DIST jedi-0.15.1.tar.gz 872898 BLAKE2B 7f20c11e0b43f9f28e6aa5c71e98339d270d7d2e269d54e926b2a33f0da84365ca2d7f34144db276bfd4006a589e3541794323f77aeb9af0ee7417c64c1d9f06 SHA512 d7810d12b3315a0cef367c5b3da8ea835ba4f64af22a29e1547c47ea6bc449b37ef74e456054c8bb7d7f9339c1b4ddf2619f5f3d34edec90178e5afd395988f7
+DIST jedi-0.17.1.tar.gz 472489 BLAKE2B 7486925cb307f6a25538c2f5d52763802222561cfc4beca1637e433f4450b06ef328204e75779b6b2ac4ca2cfcf5ab647daecd329941ca6fb0ae2a5dd2bd8b5f SHA512 0a9d552d2b4c45730c9cccf06ebb434b159b755acea0dbaddf5f628dccf8e9c752e03d151258e377b817f1a25fb9ca8e0289dbd2da290f55dc719883413b65cf
diff --git a/dev-python/jedi/jedi-0.15.1.ebuild b/dev-python/jedi/jedi-0.15.1.ebuild
deleted file mode 100644
index d99e815..0000000
--- a/dev-python/jedi/jedi-0.15.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Autocompletion library for Python"
-HOMEPAGE="https://github.com/davidhalter/jedi"
-SRC_URI="https://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/parso-0.5.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx )
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- ${RDEPEND}
- )"
-
-python_prepare_all() {
- # speed tests are fragile
- rm test/test_speed.py || die
-
- # 'path' completion test does not account for 'path' being a valid
- # package (i.e. dev-python/path-py)
- # https://github.com/davidhalter/jedi/issues/1210
- sed -i -e '/path.*not in/d' test/test_evaluate/test_imports.py || die
-
- # no clue why it fails but we don't really care about .pyc files
- # without sources anyway
- rm test/test_evaluate/test_pyc.py || die
-
- # our very useful patching changes libdir for no good reason
- sed -i -e "/site_pkg_path/s:'lib':& if virtualenv.version_info >= (3,7) else '$(get_libdir)':" \
- test/test_evaluate/test_sys_path.py || die
-
- # this super-secret feature of py3.4 apparently doesn't work for us
- sed -i -e 's:test_init_extension_module:_&:' \
- test/test_evaluate/test_extension.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -vv jedi test || die "Tests failed under ${EPYTHON}"
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( "${S}"/docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/jedi/jedi-0.14.1.ebuild b/dev-python/jedi/jedi-0.17.1.ebuild
index d99e815..d99e815 100644
--- a/dev-python/jedi/jedi-0.14.1.ebuild
+++ b/dev-python/jedi/jedi-0.17.1.ebuild