summaryrefslogtreecommitdiff
path: root/dev-python/wlc/wlc-1.10.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2021-02-18 12:22:54 +0100
committerKarel Kočí <cynerd@email.cz>2021-02-18 12:22:54 +0100
commitf243c8803f96c1e2b18855489a38e40dfffc70bf (patch)
treebe3884ce5c7c323680960c2e96bd363c79114586 /dev-python/wlc/wlc-1.10.ebuild
parent13634728d87fc6d599bb97ca5244b70c3c091b47 (diff)
downloadgentoo-personal-overlay-f243c8803f96c1e2b18855489a38e40dfffc70bf.tar.gz
gentoo-personal-overlay-f243c8803f96c1e2b18855489a38e40dfffc70bf.tar.bz2
gentoo-personal-overlay-f243c8803f96c1e2b18855489a38e40dfffc70bf.zip
dev-python/wlc: update to version 1.10
Diffstat (limited to 'dev-python/wlc/wlc-1.10.ebuild')
-rw-r--r--dev-python/wlc/wlc-1.10.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/wlc/wlc-1.10.ebuild b/dev-python/wlc/wlc-1.10.ebuild
new file mode 100644
index 0000000..0cacb4a
--- /dev/null
+++ b/dev-python/wlc/wlc-1.10.ebuild
@@ -0,0 +1,22 @@
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A command line utility for Weblate, translation tool"
+HOMEPAGE="https://weblate.org/"
+SRC_URI="https://pypi.python.org/packages/source/w/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPLv3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/argcomplete
+ dev-python/python-dateutil
+ dev-python/pyxdg
+ dev-python/requests"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}"