summaryrefslogtreecommitdiff
path: root/dev-python/schema/schema-0.7.4-r2.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2021-02-18 12:22:04 +0100
committerKarel Kočí <cynerd@email.cz>2021-02-18 12:22:04 +0100
commit13634728d87fc6d599bb97ca5244b70c3c091b47 (patch)
treef4308145152c3febb5e00a0a9a955a72446d768c /dev-python/schema/schema-0.7.4-r2.ebuild
parentc167f76548af396c3c189cfbfda599cf8499830c (diff)
downloadgentoo-personal-overlay-13634728d87fc6d599bb97ca5244b70c3c091b47.tar.gz
gentoo-personal-overlay-13634728d87fc6d599bb97ca5244b70c3c091b47.tar.bz2
gentoo-personal-overlay-13634728d87fc6d599bb97ca5244b70c3c091b47.zip
dev-python/schema: update to version 0.7.4
Diffstat (limited to 'dev-python/schema/schema-0.7.4-r2.ebuild')
-rw-r--r--dev-python/schema/schema-0.7.4-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/schema/schema-0.7.4-r2.ebuild b/dev-python/schema/schema-0.7.4-r2.ebuild
new file mode 100644
index 0000000..ad51dde
--- /dev/null
+++ b/dev-python/schema/schema-0.7.4-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for validating Python data structures"
+HOMEPAGE="https://pypi.org/project/schema/ https://github.com/keleshev/schema"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://github.com/keleshev/schema/archive/v${PV}.zip -> ${P}.tar.gz
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/contextlib2-0.5.5[${PYTHON_USEDEP}]"