summaryrefslogtreecommitdiff
path: root/dev-python/schema/schema-0.7.2-r2.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-07-24 13:46:56 +0200
committerKarel Kočí <cynerd@email.cz>2020-07-24 13:46:56 +0200
commitf643e6660721ed6b5777eb61b89f8e598e4f5c12 (patch)
tree9bf5168a57d5fba17d0b2c78c19e7fea1cc968e1 /dev-python/schema/schema-0.7.2-r2.ebuild
parent6bbec091a8eb12a4f9f331a25194d5aa454f02b3 (diff)
downloadgentoo-personal-overlay-f643e6660721ed6b5777eb61b89f8e598e4f5c12.tar.gz
gentoo-personal-overlay-f643e6660721ed6b5777eb61b89f8e598e4f5c12.tar.bz2
gentoo-personal-overlay-f643e6660721ed6b5777eb61b89f8e598e4f5c12.zip
dev-python/schema: allow newer python and newer contextlib2
Diffstat (limited to 'dev-python/schema/schema-0.7.2-r2.ebuild')
-rw-r--r--dev-python/schema/schema-0.7.2-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/schema/schema-0.7.2-r2.ebuild b/dev-python/schema/schema-0.7.2-r2.ebuild
new file mode 100644
index 0000000..ad51dde
--- /dev/null
+++ b/dev-python/schema/schema-0.7.2-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for validating Python data structures"
+HOMEPAGE="https://pypi.org/project/schema/ https://github.com/keleshev/schema"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://github.com/keleshev/schema/archive/v${PV}.zip -> ${P}.tar.gz
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/contextlib2-0.5.5[${PYTHON_USEDEP}]"