summaryrefslogtreecommitdiff
path: root/dev-python/schema/schema-0.7.0-r1.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-03-15 23:31:01 +0100
committerKarel Kočí <cynerd@email.cz>2019-03-15 23:31:01 +0100
commiteccb6dd5a503e406d4670cd5bd86fde64e7a5cf6 (patch)
tree21e2a9d70a5e430d80a85cbc0ac0222a4e0f9b1e /dev-python/schema/schema-0.7.0-r1.ebuild
parente59024b389149f3f6d1852a3463f530f29ee02b5 (diff)
downloadgentoo-personal-overlay-eccb6dd5a503e406d4670cd5bd86fde64e7a5cf6.tar.gz
gentoo-personal-overlay-eccb6dd5a503e406d4670cd5bd86fde64e7a5cf6.tar.bz2
gentoo-personal-overlay-eccb6dd5a503e406d4670cd5bd86fde64e7a5cf6.zip
dev-python/schema: version 0.7.0
Diffstat (limited to 'dev-python/schema/schema-0.7.0-r1.ebuild')
-rw-r--r--dev-python/schema/schema-0.7.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/schema/schema-0.7.0-r1.ebuild b/dev-python/schema/schema-0.7.0-r1.ebuild
new file mode 100644
index 0000000..ba8d641
--- /dev/null
+++ b/dev-python/schema/schema-0.7.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for validating Python data structures"
+HOMEPAGE="https://pypi.org/project/schema/ https://github.com/keleshev/schema"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://github.com/keleshev/schema/archive/v${PV}.zip -> ${P}.tar.gz
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ =dev-python/contextlib2-0.5.5[${PYTHON_USEDEP}]"