summaryrefslogtreecommitdiff
path: root/dev-python/schema/schema-0.6.8.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-09-30 06:56:19 +0200
committerKarel Kočí <cynerd@email.cz>2018-09-30 06:56:19 +0200
commit7842bacf3ed0b63e2be945d4de9f4a8032d72a6b (patch)
treeb2675a8db28d647d6d14f9a7fee7c8bf67e35ce2 /dev-python/schema/schema-0.6.8.ebuild
parent899525b42047650b2db431072b509af7b75fcd76 (diff)
downloadgentoo-personal-overlay-7842bacf3ed0b63e2be945d4de9f4a8032d72a6b.tar.gz
gentoo-personal-overlay-7842bacf3ed0b63e2be945d4de9f4a8032d72a6b.tar.bz2
gentoo-personal-overlay-7842bacf3ed0b63e2be945d4de9f4a8032d72a6b.zip
localy update python-schema
Diffstat (limited to 'dev-python/schema/schema-0.6.8.ebuild')
-rw-r--r--dev-python/schema/schema-0.6.8.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/schema/schema-0.6.8.ebuild b/dev-python/schema/schema-0.6.8.ebuild
new file mode 100644
index 0000000..a478507
--- /dev/null
+++ b/dev-python/schema/schema-0.6.8.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for validating Python data structures"
+HOMEPAGE="https://pypi.org/project/schema/ https://github.com/keleshev/schema"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://github.com/keleshev/schema/archive/v${PV}.zip -> ${P}.tar.gz
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"