summaryrefslogtreecommitdiff
path: root/dev-python/ruamel-yaml/ruamel-yaml-0.15.35.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-01-27 00:26:01 +0100
committerKarel Kočí <cynerd@email.cz>2018-01-27 00:26:01 +0100
commit8b143ddb579e4874cb9ca2c8672eef727964bd4f (patch)
tree50b2d0719e3e127ab73bacacc19cf2dc4c9ff693 /dev-python/ruamel-yaml/ruamel-yaml-0.15.35.ebuild
parentee7765ce8acb9584473e7f54d4531d44cd765864 (diff)
downloadgentoo-personal-overlay-8b143ddb579e4874cb9ca2c8672eef727964bd4f.tar.gz
gentoo-personal-overlay-8b143ddb579e4874cb9ca2c8672eef727964bd4f.tar.bz2
gentoo-personal-overlay-8b143ddb579e4874cb9ca2c8672eef727964bd4f.zip
Even more fixes
Diffstat (limited to 'dev-python/ruamel-yaml/ruamel-yaml-0.15.35.ebuild')
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.15.35.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.15.35.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.15.35.ebuild
new file mode 100644
index 0000000..c5144f4
--- /dev/null
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.15.35.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+inherit distutils-r1
+DESCRIPTION="YAML parser/emitter"
+HOMEPAGE="https://bitbucket.org/ruamel/yaml"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE=""
+
+if [ "${PV}" == "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://bitbucket.org/ruamel/yaml"
+else
+ SRC_URI="https://bitbucket.org/ruamel/yaml/get/${PV}.tar.gz"
+fi
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack "${A}"
+ mv "${WORKDIR}"/ruamel-yaml-* "$S"
+}
+
+src_install() {
+ distutils-r1_src_install
+}