summaryrefslogtreecommitdiff
path: root/dev-python/python-prctl/python-prctl-1.7.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-09-28 17:24:22 +0200
committerKarel Kočí <cynerd@email.cz>2018-09-28 17:24:22 +0200
commitca65443b8e6ab56a4aa18ca88a8125001006cd0c (patch)
treef33941aa141f19f5fff8b5646192d61c9e5e1bad /dev-python/python-prctl/python-prctl-1.7.ebuild
parent9253efd988a7c9922cee69e4a0148f0c5618a506 (diff)
downloadgentoo-personal-overlay-ca65443b8e6ab56a4aa18ca88a8125001006cd0c.tar.gz
gentoo-personal-overlay-ca65443b8e6ab56a4aa18ca88a8125001006cd0c.tar.bz2
gentoo-personal-overlay-ca65443b8e6ab56a4aa18ca88a8125001006cd0c.zip
dev-python/python-prctl: update to 1.7
Diffstat (limited to 'dev-python/python-prctl/python-prctl-1.7.ebuild')
-rw-r--r--dev-python/python-prctl/python-prctl-1.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-prctl/python-prctl-1.7.ebuild b/dev-python/python-prctl/python-prctl-1.7.ebuild
new file mode 100644
index 0000000..4eaf5ec
--- /dev/null
+++ b/dev-python/python-prctl/python-prctl-1.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Control process attributes through prctl"
+HOMEPAGE="https://github.com/seveas/python-prctl"
+SRC_URI="https://github.com/seveas/python-prctl/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/libcap"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}