summaryrefslogtreecommitdiff
path: root/dev-python/python-prctl/python-prctl-1.6.1.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-07-22 12:41:05 +0200
committerKarel Kočí <cynerd@email.cz>2018-07-22 12:41:05 +0200
commit0d5f47e81a01e34638c6cf8666d2dd07227f09dc (patch)
tree359aa1b8970bcaac59cb4d35e12447c69fc279bc /dev-python/python-prctl/python-prctl-1.6.1.ebuild
parent87c0f174be39e062c2a570c909eb1802ccfb5a8b (diff)
downloadgentoo-personal-overlay-0d5f47e81a01e34638c6cf8666d2dd07227f09dc.tar.gz
gentoo-personal-overlay-0d5f47e81a01e34638c6cf8666d2dd07227f09dc.tar.bz2
gentoo-personal-overlay-0d5f47e81a01e34638c6cf8666d2dd07227f09dc.zip
One more try
Diffstat (limited to 'dev-python/python-prctl/python-prctl-1.6.1.ebuild')
-rw-r--r--dev-python/python-prctl/python-prctl-1.6.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-prctl/python-prctl-1.6.1.ebuild b/dev-python/python-prctl/python-prctl-1.6.1.ebuild
new file mode 100644
index 0000000..a3fdde1
--- /dev/null
+++ b/dev-python/python-prctl/python-prctl-1.6.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Control process attributes through prctl"
+HOMEPAGE="https://github.com/seveas/python-prctl"
+SRC_URI="https://github.com/seveas/python-prctl/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/libcap"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}