summaryrefslogtreecommitdiff
path: root/dev-python/pytest-html/pytest-html-3.1.1.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-12-28 14:49:48 +0100
committerKarel Kočí <cynerd@email.cz>2020-12-28 14:49:48 +0100
commit0b3b14a3a89d2b2cbfe5b8f2b6d83fc5ec974136 (patch)
tree928c05c617fec827c1ed50d1bad453d86c4db893 /dev-python/pytest-html/pytest-html-3.1.1.ebuild
parent0469cd61ebac905a9df15ac2a1c60b383843306e (diff)
downloadgentoo-personal-overlay-0b3b14a3a89d2b2cbfe5b8f2b6d83fc5ec974136.tar.gz
gentoo-personal-overlay-0b3b14a3a89d2b2cbfe5b8f2b6d83fc5ec974136.tar.bz2
gentoo-personal-overlay-0b3b14a3a89d2b2cbfe5b8f2b6d83fc5ec974136.zip
dev-python/pytest-html: update to version 3.1.1
This also expands supported python versions.
Diffstat (limited to 'dev-python/pytest-html/pytest-html-3.1.1.ebuild')
-rw-r--r--dev-python/pytest-html/pytest-html-3.1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pytest-html/pytest-html-3.1.1.ebuild b/dev-python/pytest-html/pytest-html-3.1.1.ebuild
new file mode 100644
index 0000000..f7f7176
--- /dev/null
+++ b/dev-python/pytest-html/pytest-html-3.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for generating HTML reports for py.test results"
+HOMEPAGE="https://github.com/pytest-dev/pytest-html/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Lots of test failures...
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/pytest-5.0[${PYTHON_USEDEP}]
+ dev-python/pytest-metadata[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+python_test() {
+ PYTHONPATH=${PWD}${PYTHONPATH:+:}${PYTHONPATH} \
+ py.test -v -r a testing/test_pytest_html.py || die
+}