summaryrefslogtreecommitdiff
path: root/dev-python/pyls/pyls-0.21.4-r1.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-12-23 12:53:38 +0100
committerKarel Kočí <cynerd@email.cz>2018-12-23 12:53:38 +0100
commite968366f7b6321d5b32cbf0c1fcc77ba33c57642 (patch)
tree2ab5c5957b5436c893c09832cb6d4a38696fef86 /dev-python/pyls/pyls-0.21.4-r1.ebuild
parentade21fb188098cb808637302c0741cfe91669d30 (diff)
downloadgentoo-personal-overlay-e968366f7b6321d5b32cbf0c1fcc77ba33c57642.tar.gz
gentoo-personal-overlay-e968366f7b6321d5b32cbf0c1fcc77ba33c57642.tar.bz2
gentoo-personal-overlay-e968366f7b6321d5b32cbf0c1fcc77ba33c57642.zip
dev-python/pyls: update to version 0.21.4
Diffstat (limited to 'dev-python/pyls/pyls-0.21.4-r1.ebuild')
-rw-r--r--dev-python/pyls/pyls-0.21.4-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pyls/pyls-0.21.4-r1.ebuild b/dev-python/pyls/pyls-0.21.4-r1.ebuild
new file mode 100644
index 0000000..7983264
--- /dev/null
+++ b/dev-python/pyls/pyls-0.21.4-r1.ebuild
@@ -0,0 +1,22 @@
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Python Language Server"
+HOMEPAGE="https://github.com/palantir/python-language-server"
+SRC_URI="https://github.com/palantir/python-language-server/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/python-language-server-${PV}"
+
+LICENSE="MIT"
+KEYWORDS="amd64 ~x86"
+SLOT="0"
+IUSE=""
+PATCHES=( "${FILESDIR}/setup.py-exclude-all-test-modules.patch" )
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/future-0.14.0
+ >=dev-python/jedi-0.12
+ dev-python/jsonrpc-server
+ dev-python/pluggy"
+DEPEND="${RDEPEND}"