summaryrefslogtreecommitdiff
path: root/dev-lua/lua-compat/lua-compat-0.3.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-09-12 13:33:28 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-09-12 13:33:28 +0200
commit2ba9c6b7d5a9796b57bcdbff73efe570d65b9a0b (patch)
tree7f65335a249b2ba05a0216a92d07996dfb390a3d /dev-lua/lua-compat/lua-compat-0.3.ebuild
parent114932c5a85e316bfc647860c9064f8a09e93305 (diff)
downloadgentoo-personal-overlay-2ba9c6b7d5a9796b57bcdbff73efe570d65b9a0b.tar.gz
gentoo-personal-overlay-2ba9c6b7d5a9796b57bcdbff73efe570d65b9a0b.tar.bz2
gentoo-personal-overlay-2ba9c6b7d5a9796b57bcdbff73efe570d65b9a0b.zip
Try to fix luaposix
Diffstat (limited to 'dev-lua/lua-compat/lua-compat-0.3.ebuild')
-rw-r--r--dev-lua/lua-compat/lua-compat-0.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-lua/lua-compat/lua-compat-0.3.ebuild b/dev-lua/lua-compat/lua-compat-0.3.ebuild
new file mode 100644
index 0000000..3312df8
--- /dev/null
+++ b/dev-lua/lua-compat/lua-compat-0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lua-5.2-style APIs for Lua 5.1"
+HOMEPAGE="https://github.com/keplerproject/lua-compat-5.2"
+SRC_URI="https://github.com/keplerproject/lua-compat-5.2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+bit32 +compat52"
+
+RDEPEND="dev-lang/lua:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/lua-compat-5.2-0.3"
+
+src_compile() {
+ if use bit32; then
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
+ -o bit32.so lbitlib.c c-api/compat-5.2.c || die
+ fi
+}
+
+src_install() {
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"/term
+ if use bit32; then
+ doins bit32.so
+ fi
+ if use compat52; then
+ doins compat52.lua
+ newins compat52/strict.lua compat52.strict.lua
+ newins compat52/mstrict.lua compat52.mstrict.lua
+ fi
+}
+