summaryrefslogtreecommitdiff
path: root/dev-libs
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-08-25 16:26:33 +0200
committerKarel Kočí <cynerd@email.cz>2018-08-25 16:26:33 +0200
commitd4476625eaf1b3c59c8212a9054d8609a45f7ef6 (patch)
tree552d26d7314c75ca8762f7f7fb3931c0c36c4ff1 /dev-libs
parent01fb9de4b2ac49b42c557709e7259702138df59c (diff)
downloadgentoo-personal-overlay-d4476625eaf1b3c59c8212a9054d8609a45f7ef6.tar.gz
gentoo-personal-overlay-d4476625eaf1b3c59c8212a9054d8609a45f7ef6.tar.bz2
gentoo-personal-overlay-d4476625eaf1b3c59c8212a9054d8609a45f7ef6.zip
Try to use somewhat new capnproto
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/capnproto/capnproto-0.6.1.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/capnproto/capnproto-0.6.1.1.ebuild b/dev-libs/capnproto/capnproto-0.6.1.1.ebuild
new file mode 100644
index 0000000..fa49b5d
--- /dev/null
+++ b/dev-libs/capnproto/capnproto-0.6.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="RPC/Serialization system with capabilities support"
+HOMEPAGE="https://capnproto.org"
+SRC_URI="https://github.com/sandstorm-io/capnproto/archive/3079784bfaf3ba05edacfc63d6d494b76a85a3a5.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/061"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="static-libs test"
+
+RDEPEND=""
+DEPEND="test? ( dev-cpp/gtest )"
+
+S=${WORKDIR}/${P}/c++
+
+src_prepare() {
+ sed -e 's/ldconfig/true/' -i Makefile.am || die
+ sed -e 's#gtest/lib/libgtest.la gtest/lib/libgtest_main.la#-lgtest -lgtest_main#' -i Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete
+}