summaryrefslogtreecommitdiff
path: root/dev-libs/capnproto/capnproto-0.7.0.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-10-08 11:35:16 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-10-08 11:35:16 +0200
commitfc6da856cd6955ce41ba47ed8bfd7119e73d7565 (patch)
treeb32936c8a2d8ca7e575f32c81c9f929366537872 /dev-libs/capnproto/capnproto-0.7.0.ebuild
parentd596e3c3d516893c6619d2256ed70a50cf0a4ed8 (diff)
downloadgentoo-personal-overlay-fc6da856cd6955ce41ba47ed8bfd7119e73d7565.tar.gz
gentoo-personal-overlay-fc6da856cd6955ce41ba47ed8bfd7119e73d7565.tar.bz2
gentoo-personal-overlay-fc6da856cd6955ce41ba47ed8bfd7119e73d7565.zip
dev-libs/capnproto: update to version 0.7.0
Diffstat (limited to 'dev-libs/capnproto/capnproto-0.7.0.ebuild')
-rw-r--r--dev-libs/capnproto/capnproto-0.7.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/capnproto/capnproto-0.7.0.ebuild b/dev-libs/capnproto/capnproto-0.7.0.ebuild
new file mode 100644
index 0000000..6d681e7
--- /dev/null
+++ b/dev-libs/capnproto/capnproto-0.7.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="RPC/Serialization system with capabilities support"
+HOMEPAGE="https://capnproto.org"
+SRC_URI="https://github.com/sandstorm-io/capnproto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/061"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="static-libs test"
+
+RDEPEND=""
+DEPEND="test? ( dev-cpp/gtest )"
+
+S="${WORKDIR}/capnproto-${PV}/c++"
+
+src_prepare() {
+ sed -e 's/ldconfig/true/' -i Makefile.am || die
+ sed -e 's#gtest/lib/libgtest.la gtest/lib/libgtest_main.la#-lgtest -lgtest_main#' -i Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete
+}