summaryrefslogtreecommitdiff
path: root/dev-libs/base64c/base64c-0.2.0.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-07-23 16:06:12 +0200
committerKarel Kočí <cynerd@email.cz>2020-07-23 16:06:12 +0200
commit88d65597b86291c13b6b2bdb89a9ec9219720f33 (patch)
tree8269df0a8bfd5552edc13b2216d1eb517ae14ac9 /dev-libs/base64c/base64c-0.2.0.ebuild
parent37e88191e23239f6f2c9cf79165c072246693e74 (diff)
downloadgentoo-personal-overlay-88d65597b86291c13b6b2bdb89a9ec9219720f33.tar.gz
gentoo-personal-overlay-88d65597b86291c13b6b2bdb89a9ec9219720f33.tar.bz2
gentoo-personal-overlay-88d65597b86291c13b6b2bdb89a9ec9219720f33.zip
dev-libs/base64c: update to version 0.2.0
Diffstat (limited to 'dev-libs/base64c/base64c-0.2.0.ebuild')
-rw-r--r--dev-libs/base64c/base64c-0.2.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-libs/base64c/base64c-0.2.0.ebuild b/dev-libs/base64c/base64c-0.2.0.ebuild
new file mode 100644
index 0000000..da8c926
--- /dev/null
+++ b/dev-libs/base64c/base64c-0.2.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Base64 encoding/decoding library for C"
+HOMEPAGE="https://gitlab.nic.cz/turris/base64c/-/tree/master"
+SRC_URI="https://gitlab.nic.cz/turris/base64c/-/archive/v${PV}/base64c-v${PV}.tar.gz"
+S="${WORKDIR}/base64c-v${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ ./bootstrap
+ econf \
+ --disable-tests \
+ --disable-valgrind \
+ --disable-linters
+}