summaryrefslogtreecommitdiff
path: root/app-shells
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-07-07 13:02:25 +0200
committerKarel Kočí <cynerd@email.cz>2020-07-07 13:02:25 +0200
commit53174a05ee51bed8bb1e9d28943a603ee63f0f82 (patch)
treebd1bf79ee87494e2569756ffe24cb525f6b7b1e3 /app-shells
parent3e78cd0c93ff64be3bfb8820fb1dbf56971dac32 (diff)
downloadgentoo-personal-overlay-53174a05ee51bed8bb1e9d28943a603ee63f0f82.tar.gz
gentoo-personal-overlay-53174a05ee51bed8bb1e9d28943a603ee63f0f82.tar.bz2
gentoo-personal-overlay-53174a05ee51bed8bb1e9d28943a603ee63f0f82.zip
app-shells/lxd-zsh-completions: fix awk syntax error by patch
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/lxd-zsh-completions/files/lxd-zsh-completions-fix-awk-syntax-error.patch34
-rw-r--r--app-shells/lxd-zsh-completions/lxd-zsh-completions-20190522-r1.ebuild (renamed from app-shells/lxd-zsh-completions/lxd-zsh-completions-20190522.ebuild)4
2 files changed, 38 insertions, 0 deletions
diff --git a/app-shells/lxd-zsh-completions/files/lxd-zsh-completions-fix-awk-syntax-error.patch b/app-shells/lxd-zsh-completions/files/lxd-zsh-completions-fix-awk-syntax-error.patch
new file mode 100644
index 0000000..1884e68
--- /dev/null
+++ b/app-shells/lxd-zsh-completions/files/lxd-zsh-completions-fix-awk-syntax-error.patch
@@ -0,0 +1,34 @@
+From d33f60339259e5e8a345b8b1091e3e4158758b27 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <karel.koci@nic.cz>
+Date: Wed, 18 Sep 2019 09:53:10 +0200
+Subject: [PATCH] Fix awk script syntax error
+
+Space does not have to be escaped and awk is annoyingly producing
+warning about it to terminal.
+This just removes unnecessary escape of spaces in regexp.
+---
+ _lxc | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/_lxc b/_lxc
+index e9ef9f1..420be6d 100644
+--- a/_lxc
++++ b/_lxc
+@@ -837,12 +837,12 @@ __lxc_containers_all () {
+
+ __lxc_images_as_fingerprint () {
+ local -a _l
+- _l=(${(@f)"$(_call_program images lxc image list | tail -n +4 | egrep -e '^\|' | awk '{split($0,a,"|"); for(i in a){ sub(/^[\ \t]+/,"",a[i]);sub(/[\ \t]+$/,"",a[i]);}; (a[2]=="") ? b=" (not aliased)" : b=" (aliased as " a[2] ")" ; print a[3] ":" a[5] b }' )"})
++ _l=(${(@f)"$(_call_program images lxc image list | tail -n +4 | egrep -e '^\|' | awk '{split($0,a,"|"); for(i in a){ sub(/^[ \t]+/,"",a[i]);sub(/[ \t]+$/,"",a[i]);}; (a[2]=="") ? b=" (not aliased)" : b=" (aliased as " a[2] ")" ; print a[3] ":" a[5] b }' )"})
+ _describe -t images_as_fingerprint 'Images as fingerprint' _l
+ }
+
+ __lxc_images_as_alias () {
+- _l=(${(@f)"$(_call_program images lxc image alias list | tail -n +4 | egrep -e '^\|' | awk '{split($0,a,"|"); for(i in a){ sub(/^[\ \t]+/,"",a[i]);sub(/[\ \t]+$/,"",a[i]);}; (a[4]=="") ? b="" : b=" - " a[4] ;print a[2] ":" a[3] b }' )"})
++ _l=(${(@f)"$(_call_program images lxc image alias list | tail -n +4 | egrep -e '^\|' | awk '{split($0,a,"|"); for(i in a){ sub(/^[ \t]+/,"",a[i]);sub(/[ \t]+$/,"",a[i]);}; (a[4]=="") ? b="" : b=" - " a[4] ;print a[2] ":" a[3] b }' )"})
+ _describe -t images_as_alias 'Images as alias' _l
+ }
+
+--
+2.27.0
+
diff --git a/app-shells/lxd-zsh-completions/lxd-zsh-completions-20190522.ebuild b/app-shells/lxd-zsh-completions/lxd-zsh-completions-20190522-r1.ebuild
index bbde865..d3a485a 100644
--- a/app-shells/lxd-zsh-completions/lxd-zsh-completions-20190522.ebuild
+++ b/app-shells/lxd-zsh-completions/lxd-zsh-completions-20190522-r1.ebuild
@@ -17,6 +17,10 @@ IUSE=""
DEPEND="app-shells/zsh"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/${P}-fix-awk-syntax-error.patch"
+)
+
src_install() {
insinto /usr/share/zsh/site-functions
doins _lxc