summaryrefslogtreecommitdiff
path: root/app-misc/khal/khal-0.9.9.ebuild
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-07-19 21:36:15 +0200
committerKarel Kočí <cynerd@email.cz>2018-07-19 21:36:15 +0200
commit44d22113b8232413aead317c3e42048ce5fa78c3 (patch)
tree24153608624aa230dd2cebd4ee6fa6f2e5159a79 /app-misc/khal/khal-0.9.9.ebuild
parent7bf03ff7417751467d8489f7288de36e37a979c2 (diff)
downloadgentoo-personal-overlay-44d22113b8232413aead317c3e42048ce5fa78c3.tar.gz
gentoo-personal-overlay-44d22113b8232413aead317c3e42048ce5fa78c3.tar.bz2
gentoo-personal-overlay-44d22113b8232413aead317c3e42048ce5fa78c3.zip
app-misc: add support for pyton 3.7 and update khal
Diffstat (limited to 'app-misc/khal/khal-0.9.9.ebuild')
-rw-r--r--app-misc/khal/khal-0.9.9.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/khal/khal-0.9.9.ebuild b/app-misc/khal/khal-0.9.9.ebuild
new file mode 100644
index 0000000..60e8fe9
--- /dev/null
+++ b/app-misc/khal/khal-0.9.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A CalDAV based calendar"
+HOMEPAGE="http://lostpackets.de/khal/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="zsh-completion"
+
+RDEPEND=">=dev-python/click-3.2[${PYTHON_USEDEP}]
+ >=dev-python/click-log-0.1.3[${PYTHON_USEDEP}]
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/atomicwrites-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/tzlocal-1.0[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ zsh-completion? ( app-shells/zsh )"
+
+DEPEND=">dev-python/setuptools_scm-1.12.0[${PYTHON_USEDEP}]
+ dev-python/freezegun"
+
+DOCS=( AUTHORS.txt CHANGELOG.rst CONTRIBUTING.rst README.rst khal.conf.sample )
+
+src_install() {
+ distutils-r1_src_install
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ doins misc/__khal
+ fi
+}