summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-12-05 21:50:43 +0100
committerKarel Kočí <cynerd@email.cz>2018-12-05 21:50:43 +0100
commitfdcb36160439aae6bdf6a3234b75db373be49c20 (patch)
tree7406037e0b9526602732402f0aaad270831c5a3c
parentcf438c686e2374eb5d09bee57da6aae786bcb058 (diff)
downloadgentoo-personal-overlay-fdcb36160439aae6bdf6a3234b75db373be49c20.tar.gz
gentoo-personal-overlay-fdcb36160439aae6bdf6a3234b75db373be49c20.tar.bz2
gentoo-personal-overlay-fdcb36160439aae6bdf6a3234b75db373be49c20.zip
dev-python/icalendar: update to version to be send to upstream
-rw-r--r--dev-python/icalendar/icalendar-4.0.3-r1.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/dev-python/icalendar/icalendar-4.0.3-r1.ebuild b/dev-python/icalendar/icalendar-4.0.3-r1.ebuild
index 015b5a6..f903290 100644
--- a/dev-python/icalendar/icalendar-4.0.3-r1.ebuild
+++ b/dev-python/icalendar/icalendar-4.0.3-r1.ebuild
@@ -3,12 +3,10 @@
EAPI="6"
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
inherit distutils-r1
-MY_PN="collective-${PN}"
-
DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
HOMEPAGE="https://github.com/collective/icalendar"
SRC_URI="mirror://pypi/i/${PN}/${P}.tar.gz"
@@ -20,29 +18,25 @@ IUSE="doc test"
DOCS="README.rst"
RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]"
+ dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="
${RDEPEND}
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/python-dateutil:0[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}] )"
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
python_prepare_all() {
# reset conf.py to not read version from an installed instance
- sed -e "s:pkg_resources.get_distribution('icalendar').version:'3.9.0':" \
+ sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
-i docs/conf.py || die
distutils-r1_python_prepare_all
}
python_compile_all() {
if use doc; then
- pushd docs > /dev/null
- emake text
- popd > /dev/null
+ emake -C docs text
DOCS=( ${DOCS} docs/_build/text/*.txt )
fi
}