summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-03-28 13:33:30 +0200
committerKarel Kočí <cynerd@email.cz>2018-03-28 13:33:30 +0200
commitccc3d0e0587908a8b4a4516a04250bd612a1b6fd (patch)
tree366843f743dee04ff1f671ba45438b171000afe6
parent337032f674e5cce2c4be844cf0a4f5a6d8915c01 (diff)
downloadgentoo-personal-overlay-ccc3d0e0587908a8b4a4516a04250bd612a1b6fd.tar.gz
gentoo-personal-overlay-ccc3d0e0587908a8b4a4516a04250bd612a1b6fd.tar.bz2
gentoo-personal-overlay-ccc3d0e0587908a8b4a4516a04250bd612a1b6fd.zip
Add cpu specific profiles and use them as base
-rw-r--r--profiles/amd/parent1
-rw-r--r--profiles/cynerd-desktop/parent2
-rw-r--r--profiles/cynerd-laptop/parent1
-rw-r--r--profiles/intel/parent1
-rw-r--r--profiles/profiles.desc1
-rw-r--r--profiles/work-pc/parent2
-rw-r--r--sys-kernel/linux/linux-4.15.13-r1.ebuild5
7 files changed, 6 insertions, 7 deletions
diff --git a/profiles/amd/parent b/profiles/amd/parent
new file mode 100644
index 0000000..d5b1fb1
--- /dev/null
+++ b/profiles/amd/parent
@@ -0,0 +1 @@
+../base/amd64/desktop
diff --git a/profiles/cynerd-desktop/parent b/profiles/cynerd-desktop/parent
index e160d48..e613464 100644
--- a/profiles/cynerd-desktop/parent
+++ b/profiles/cynerd-desktop/parent
@@ -1,4 +1,4 @@
-../base/amd64
+../amd
../desktop/x
../devel
../latex
diff --git a/profiles/cynerd-laptop/parent b/profiles/cynerd-laptop/parent
index ba5557b..44cb85c 100644
--- a/profiles/cynerd-laptop/parent
+++ b/profiles/cynerd-laptop/parent
@@ -1,4 +1,3 @@
-../base/amd64
../intel
../laptop
../qemu
diff --git a/profiles/intel/parent b/profiles/intel/parent
new file mode 100644
index 0000000..d5b1fb1
--- /dev/null
+++ b/profiles/intel/parent
@@ -0,0 +1 @@
+../base/amd64/desktop
diff --git a/profiles/profiles.desc b/profiles/profiles.desc
index 0b357a0..61f5f8f 100644
--- a/profiles/profiles.desc
+++ b/profiles/profiles.desc
@@ -1,6 +1,5 @@
amd64 cynerd-desktop stable
amd64 cynerd-laptop stable
-amd64 cynerd-pc stable
amd64 work-pc stable
amd64 cynerd-server stable
amd64 usb-boot/amd64 stable
diff --git a/profiles/work-pc/parent b/profiles/work-pc/parent
index f6abf61..910277b 100644
--- a/profiles/work-pc/parent
+++ b/profiles/work-pc/parent
@@ -1,4 +1,4 @@
-../base/amd64
+../intel
../desktop/x
../intel
../qemu
diff --git a/sys-kernel/linux/linux-4.15.13-r1.ebuild b/sys-kernel/linux/linux-4.15.13-r1.ebuild
index dbdbf2a..a450a55 100644
--- a/sys-kernel/linux/linux-4.15.13-r1.ebuild
+++ b/sys-kernel/linux/linux-4.15.13-r1.ebuild
@@ -14,10 +14,9 @@ S="${WORKDIR}/linux-stable-${VER}"
LICENSE="GPLv2"
SLOT="${PV}"
KEYWORDS="amd64 ~x86"
-IUSE="virt +initramfs amd intel"
+IUSE="virt initramfs amd intel"
DEPEND="
- initramfs? ( sys-boot/myinitramfs )
sys-devel/bc
dev-libs/elfutils"
@@ -71,7 +70,7 @@ pkg_postinst() {
sysfile
if ! grep -q "^LABEL gentoo-${PV}$" "${SYSLINUX}"; then
if $(use initramfs); then
- INITRD="\tINITRD ${PFIX}/initramfs-${PV}\n"
+ INITRD="\tINITRD ${PFIX}/initramfs-gentoo\n"
fi
ARGS="$(grep -E "^# ARGS: " "${SYSLINUX}" | sed 's/^# ARGS: //')"
if [ -n "$ARGS" ]; then