summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-11-05 20:20:31 +0100
committerKarel Kočí <cynerd@email.cz>2018-11-05 20:20:31 +0100
commit933fd869ef8c1492b7ae0848695fca6f758f8277 (patch)
tree6162fc3cb29cba8e4888987b641439e3b27a7b34
parentd1ee0e4ce8a19dfe80e5776d6b5cd5c87505e540 (diff)
downloadgentoo-personal-overlay-933fd869ef8c1492b7ae0848695fca6f758f8277.tar.gz
gentoo-personal-overlay-933fd869ef8c1492b7ae0848695fca6f758f8277.tar.bz2
gentoo-personal-overlay-933fd869ef8c1492b7ae0848695fca6f758f8277.zip
dev-libs/sway: try to update to latest beta
-rw-r--r--dev-libs/sway/Manifest1
-rw-r--r--dev-libs/sway/sway-1.0-r1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/sway/Manifest b/dev-libs/sway/Manifest
new file mode 100644
index 0000000..b260b24
--- /dev/null
+++ b/dev-libs/sway/Manifest
@@ -0,0 +1 @@
+DIST sway-1.0.tar.gz 5444424 BLAKE2B b2803b6770ac3fbb3c21b892a208008e60780b6002e983e6d144d4f97e04992d3a3e5589abe36042221d67a107e31f5e76ae193cbf3e36c71fcf027095140944 SHA512 745b16be7641446c54e1b8777be1f8a26e8275f7826590f594bf4a2001a6de42e394b602e1ccd26a1e8ebe256fde6f9b393f5560a1dd0a610867819076645c69
diff --git a/dev-libs/sway/sway-1.0-r1.ebuild b/dev-libs/sway/sway-1.0-r1.ebuild
new file mode 100644
index 0000000..e5d7948
--- /dev/null
+++ b/dev-libs/sway/sway-1.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils meson ninja-utils
+
+DESCRIPTION="i3-compatible Wayland window manager"
+HOMEPAGE="http://swaywm.org/"
+
+SRC_URI="https://github.com/swaywm/sway/archive/1.0-beta.1.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+# TODO
+IUSE="wallpapers bash-completion zsh-completion +xwayland"
+
+RDEPEND="
+ dev-libs/wlroots
+ xwayland? ( dev-libs/wlroots[x11-backend] )
+ dev-libs/wayland
+ x11-base/xorg-server[wayland]
+ >=dev-libs/libinput-1.6.0
+ sys-libs/libcap
+ dev-libs/libpcre
+ >=dev-libs/json-c-0.13:0=
+ x11-libs/pango
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf[jpeg]
+ virtual/pam
+ >=sys-apps/dbus-1.10
+ "
+
+DEPEND="${RDEPEND}
+ dev-util/meson
+ app-text/scdoc
+ virtual/pkgconfig"
+
+src_configure() {
+ local emesonargs=(
+ -Ddefault-wallpaper=$(usex wallpapers)
+ -Dzsh-completions=$(usex zsh-completion)
+ -Dbash-completions=$(usex bash-completion)
+ -Denable-xwayland=$(usex xwayland)
+ )
+ meson_src_configure
+}