summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-05-01 13:59:33 +0200
committerKarel Kočí <cynerd@email.cz>2017-05-01 13:59:33 +0200
commit4980e365ae205d89137105511de7e8858dca05b1 (patch)
tree0819491606f097633dc930a1d4e945bd337d3315
parentf892939039073825f0917198a7972f57b85f2112 (diff)
downloadgentoo-personal-overlay-4980e365ae205d89137105511de7e8858dca05b1.tar.gz
gentoo-personal-overlay-4980e365ae205d89137105511de7e8858dca05b1.tar.bz2
gentoo-personal-overlay-4980e365ae205d89137105511de7e8858dca05b1.zip
fix postinst and prerm function names
-rw-r--r--sys-kernel/linux/linux-4.10.13.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-kernel/linux/linux-4.10.13.ebuild b/sys-kernel/linux/linux-4.10.13.ebuild
index f9d648b..c1c88a8 100644
--- a/sys-kernel/linux/linux-4.10.13.ebuild
+++ b/sys-kernel/linux/linux-4.10.13.ebuild
@@ -31,14 +31,14 @@ src_install() {
newins "${S}/arch/$ARCH/boot/bzImage" "bzlinux-${PV}"
}
-src_postinst() {
+pkg_postinst() {
# Add label to syslinux config if there is non yet
if ! grep -q "^LABEL gentoo-${PV}$" /boot/syslinux/syslinux.cfg; then
sed -i "/^## Dynamic labels ##$/a LABEL gentoo-${PV}\n\tMENU LABEL Gentoo${PV}\n\tLINUX ../bzlinux-${PV}\n\tAPPEND root=/dev/sda2 rootflags=subvol=@gentoo\n\tINITRD ../initramfs-gentoo\n" /boot/syslinux/syslinux.cfg || eerror "Adding label to syslinux configuration failed!"
fi
}
-src_prerm() {
+pkg_prerm() {
# Remove label from syslinux config
sed -i "/^LABEL gentoo-${PV}$/,/^$/d" /boot/syslinux/syslinux.cfg || eerror "Removing label from syslinux fonfiguration failed!"
}