summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-05-08 20:42:48 +0200
committerKarel Kočí <cynerd@email.cz>2017-05-08 20:42:48 +0200
commit469c335141506fcb62f855c66b23c7d6a278924a (patch)
tree2a7eea4493916d5ac45d0a48ed2f8db56d4d50fe
parent44a923b4710f000163a94a0bd4f1db19b25d0377 (diff)
downloadgentoo-personal-overlay-469c335141506fcb62f855c66b23c7d6a278924a.tar.gz
gentoo-personal-overlay-469c335141506fcb62f855c66b23c7d6a278924a.tar.bz2
gentoo-personal-overlay-469c335141506fcb62f855c66b23c7d6a278924a.zip
Revert missmerge
-rw-r--r--sci-electronics/ghdl/files/ghdl-0.29-gcc.patch132
-rw-r--r--sci-electronics/ghdl/ghdl-0.33.ebuild18
2 files changed, 0 insertions, 150 deletions
diff --git a/sci-electronics/ghdl/files/ghdl-0.29-gcc.patch b/sci-electronics/ghdl/files/ghdl-0.29-gcc.patch
deleted file mode 100644
index b819371..0000000
--- a/sci-electronics/ghdl/files/ghdl-0.29-gcc.patch
+++ /dev/null
@@ -1,132 +0,0 @@
-diff --git a/gcc/config/alpha/linux-unwind.h b/gcc/config/alpha/linux-unwind.h
-index 23151ad..1b2d9d0 100644
---- a/gcc/config/alpha/linux-unwind.h
-+++ b/gcc/config/alpha/linux-unwind.h
-@@ -52,7 +52,7 @@ alpha_fallback_frame_state (struct _Unwind_Context *context,
- else if (pc[1] == 0x201f015f) /* lda $0,NR_rt_sigreturn */
- {
- struct rt_sigframe {
-- struct siginfo info;
-+ siginfo_t info;
- struct ucontext uc;
- } *rt_ = context->cfa;
- sc = &rt_->uc.uc_mcontext;
-diff --git a/gcc/config/bfin/linux-unwind.h b/gcc/config/bfin/linux-unwind.h
-index c369711..90c91a3 100644
---- a/gcc/config/bfin/linux-unwind.h
-+++ b/gcc/config/bfin/linux-unwind.h
-@@ -52,10 +52,10 @@ bfin_fallback_frame_state (struct _Unwind_Context *context,
- {
- struct rt_sigframe {
- int sig;
-- struct siginfo *pinfo;
-+ siginfo_t *pinfo;
- void *puc;
- char retcode[8];
-- struct siginfo info;
-+ siginfo_t info;
- struct ucontext uc;
- } *rt_ = context->cfa;
-
-diff --git a/gcc/config/i386/linux-unwind.h b/gcc/config/i386/linux-unwind.h
-index 58eb733..9808925 100644
---- a/gcc/config/i386/linux-unwind.h
-+++ b/gcc/config/i386/linux-unwind.h
-@@ -137,9 +137,9 @@ x86_fallback_frame_state (struct _Unwind_Context *context,
- {
- struct rt_sigframe {
- int sig;
-- struct siginfo *pinfo;
-+ siginfo_t *pinfo;
- void *puc;
-- struct siginfo info;
-+ siginfo_t info;
- struct ucontext uc;
- } *rt_ = context->cfa;
- /* The void * cast is necessary to avoid an aliasing warning.
-diff --git a/gcc/config/ia64/linux-unwind.h b/gcc/config/ia64/linux-unwind.h
-index 8b2878e..bbc77e6 100644
---- a/gcc/config/ia64/linux-unwind.h
-+++ b/gcc/config/ia64/linux-unwind.h
-@@ -51,7 +51,7 @@ ia64_fallback_frame_state (struct _Unwind_Context *context,
- struct sigframe {
- char scratch[16];
- unsigned long sig_number;
-- struct siginfo *info;
-+ siginfo_t *info;
- struct sigcontext *sc;
- } *frame_ = (struct sigframe *)context->psp;
- struct sigcontext *sc = frame_->sc;
-@@ -130,7 +130,7 @@ ia64_handle_unwabi (struct _Unwind_Context *context, _Unwind_FrameState *fs)
- struct sigframe {
- char scratch[16];
- unsigned long sig_number;
-- struct siginfo *info;
-+ siginfo_t *info;
- struct sigcontext *sc;
- } *frame = (struct sigframe *)context->psp;
- struct sigcontext *sc = frame->sc;
-diff --git a/gcc/config/mips/linux-unwind.h b/gcc/config/mips/linux-unwind.h
-index 4e71182..86d4711 100644
---- a/gcc/config/mips/linux-unwind.h
-+++ b/gcc/config/mips/linux-unwind.h
-@@ -79,7 +79,7 @@ mips_fallback_frame_state (struct _Unwind_Context *context,
- struct rt_sigframe {
- u_int32_t ass[4]; /* Argument save space for o32. */
- u_int32_t trampoline[2];
-- struct siginfo info;
-+ siginfo_t info;
- _sig_ucontext_t uc;
- } *rt_ = context->cfa;
- sc = &rt_->uc.uc_mcontext;
-diff --git a/gcc/config/pa/linux-unwind.h b/gcc/config/pa/linux-unwind.h
-index 812561e..84ab137 100644
---- a/gcc/config/pa/linux-unwind.h
-+++ b/gcc/config/pa/linux-unwind.h
-@@ -66,7 +66,7 @@ pa32_fallback_frame_state (struct _Unwind_Context *context,
- int i;
- struct sigcontext *sc;
- struct rt_sigframe {
-- struct siginfo info;
-+ siginfo_t info;
- struct ucontext uc;
- } *frame;
-
-diff --git a/gcc/config/sh/linux-unwind.h b/gcc/config/sh/linux-unwind.h
-index 3a3e9aa..7699729 100644
---- a/gcc/config/sh/linux-unwind.h
-+++ b/gcc/config/sh/linux-unwind.h
-@@ -80,9 +80,9 @@ shmedia_fallback_frame_state (struct _Unwind_Context *context,
- && (*(unsigned long *) (pc+11) == 0x6ff0fff0))
- {
- struct rt_sigframe {
-- struct siginfo *pinfo;
-+ siginfo_t *pinfo;
- void *puc;
-- struct siginfo info;
-+ siginfo_t info;
- struct ucontext uc;
- } *rt_ = context->cfa;
- /* The void * cast is necessary to avoid an aliasing warning.
-@@ -179,7 +179,7 @@ sh_fallback_frame_state (struct _Unwind_Context *context,
- && (*(unsigned short *) (pc+14) == 0x00ad))))
- {
- struct rt_sigframe {
-- struct siginfo info;
-+ siginfo_t info;
- struct ucontext uc;
- } *rt_ = context->cfa;
- /* The void * cast is necessary to avoid an aliasing warning.
-diff --git a/gcc/config/xtensa/linux-unwind.h b/gcc/config/xtensa/linux-unwind.h
-index 18daff2..2a5e4f8 100644
---- a/gcc/config/xtensa/linux-unwind.h
-+++ b/gcc/config/xtensa/linux-unwind.h
-@@ -66,7 +66,7 @@ xtensa_fallback_frame_state (struct _Unwind_Context *context,
- struct sigcontext *sc;
-
- struct rt_sigframe {
-- struct siginfo info;
-+ siginfo_t info;
- struct ucontext uc;
- } *rt_;
-
diff --git a/sci-electronics/ghdl/ghdl-0.33.ebuild b/sci-electronics/ghdl/ghdl-0.33.ebuild
deleted file mode 100644
index 402412e..0000000
--- a/sci-electronics/ghdl/ghdl-0.33.ebuild
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-DESCRIPTION="Complete VHDL simulator using the GCC technology"
-HOMEPAGE="http://ghdl.free.fr"
-SRC_URI="https://github.com/tgingold/ghdl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-lang/gnat-gcc"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
-}