summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-02-21 14:43:23 +0100
committerKarel Kočí <cynerd@email.cz>2022-02-21 14:43:23 +0100
commit38c0371cece432682a68dc97454dde2216ba0192 (patch)
tree019c37c4fdbdabfe34a647e4575e363010b7a138
parent3e210abe723ed0fd7b1e14b551b6ed54aba6e759 (diff)
downloadgentoo-personal-overlay-38c0371cece432682a68dc97454dde2216ba0192.tar.gz
gentoo-personal-overlay-38c0371cece432682a68dc97454dde2216ba0192.tar.bz2
gentoo-personal-overlay-38c0371cece432682a68dc97454dde2216ba0192.zip
gui-apps/wayvnc: update to 0.4.1
-rw-r--r--gui-apps/wayvnc/Manifest1
-rw-r--r--gui-apps/wayvnc/wayvnc-0.4.1-r1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/gui-apps/wayvnc/Manifest b/gui-apps/wayvnc/Manifest
new file mode 100644
index 0000000..e374025
--- /dev/null
+++ b/gui-apps/wayvnc/Manifest
@@ -0,0 +1 @@
+DIST wayvnc-0.4.1.tar.gz 52169 BLAKE2B eae7050aec9bf750897df3a7f153533411a88f047b9c24cd42caecb01cd0588d52e4f24edee5dd314934a5f79cf0bc8b76061136d663d4ef4e62e899badfad92 SHA512 6cffaa198e3baad172c7befa413ba21b03985f1acc936200cbde94d98d125ef804b0f30d355ea0aeb9e50624a01d2db499bed5bf6d3f01a7d1db3308c7fc605f
diff --git a/gui-apps/wayvnc/wayvnc-0.4.1-r1.ebuild b/gui-apps/wayvnc/wayvnc-0.4.1-r1.ebuild
new file mode 100644
index 0000000..e865d2f
--- /dev/null
+++ b/gui-apps/wayvnc/wayvnc-0.4.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="VNC server for wlroots based Wayland compositors"
+HOMEPAGE="https://github.com/any1/wayvnc"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/wayvnc.git"
+else
+ SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="gbm tracing"
+
+RDEPEND="
+ dev-libs/aml
+ dev-libs/wayland
+ gui-libs/neatvnc[tracing?]
+ media-libs/mesa:=[egl(+),gles2,gbm(+)?]
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ tracing? ( dev-util/systemtap )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature gbm screencopy-dmabuf)
+ $(meson_use tracing systemtap)
+ )
+ meson_src_configure
+}