summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-04-17 15:29:31 +0200
committerKarel Kočí <cynerd@email.cz>2020-04-17 15:29:31 +0200
commit0c38274892ef31fdec18a667adc91a47380bae18 (patch)
tree80715c453086325e9330666fd36039f9ffe59dad
parent51c8161e99400212fdc6a5a0ec07366eb4bfe7a1 (diff)
downloadgentoo-personal-overlay-0c38274892ef31fdec18a667adc91a47380bae18.tar.gz
gentoo-personal-overlay-0c38274892ef31fdec18a667adc91a47380bae18.tar.bz2
gentoo-personal-overlay-0c38274892ef31fdec18a667adc91a47380bae18.zip
dev-embedded/libftdi: try to compile for newer python versions
-rw-r--r--dev-embedded/libftdi/Manifest1
-rw-r--r--dev-embedded/libftdi/libftdi-1.4.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-embedded/libftdi/Manifest b/dev-embedded/libftdi/Manifest
new file mode 100644
index 0000000..83e5673
--- /dev/null
+++ b/dev-embedded/libftdi/Manifest
@@ -0,0 +1 @@
+DIST libftdi1-1.4.tar.bz2 109521 BLAKE2B 4186342afb2a0118c454230a925ccff2ed0aedd942cdd3afb1ac59519f1cd48db7f04421ecdb5aa6e53993666a903de00ce447fd81d00839806f8cc0d34c6e52 SHA512 dbab74f7bc35ca835b9c6dd5b70a64816948d65da1f73a9ece37a0f0f630bd0df1a676543acc517b02a718bc34ba4f7a30cbc48b6eed1c154c917f8ef0a358fc
diff --git a/dev-embedded/libftdi/libftdi-1.4.ebuild b/dev-embedded/libftdi/libftdi-1.4.ebuild
new file mode 100644
index 0000000..62be462
--- /dev/null
+++ b/dev-embedded/libftdi/libftdi-1.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit cmake-utils python-single-r1
+
+MY_P="${PN}1-${PV}"
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://developer.intra2net.com/${PN}"
+else
+ SRC_URI="http://www.intra2net.com/en/developer/${PN}/download/${MY_P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Userspace access to FTDI USB interface chips"
+HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
+
+LICENSE="LGPL-2"
+SLOT="1"
+IUSE="cxx doc examples python static-libs test tools"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="virtual/libusb:1
+ cxx? ( dev-libs/boost )
+ python? ( ${PYTHON_DEPS} )
+ tools? (
+ !<dev-embedded/ftdi_eeprom-1.0
+ dev-libs/confuse:=
+ )"
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ doc? ( app-doc/doxygen )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local mycmakeargs=(
+ -DFTDIPP=$(usex cxx)
+ -DDOCUMENTATION=$(usex doc)
+ -DEXAMPLES=$(usex examples)
+ -DPYTHON_BINDINGS=$(usex python)
+ -DSTATICLIBS=$(usex static-libs)
+ -DBUILD_TESTS=$(usex test)
+ -DFTDI_EEPROM=$(usex tools)
+ -DCMAKE_SKIP_BUILD_RPATH=ON
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use python && python_optimize
+ dodoc AUTHORS ChangeLog README TODO
+
+ if use doc ; then
+ # Clean up crap man pages. #356369
+ rm -vf "${CMAKE_BUILD_DIR}"/doc/man/man3/_* || die
+
+ doman "${CMAKE_BUILD_DIR}"/doc/man/man3/*
+ dodoc -r "${CMAKE_BUILD_DIR}"/doc/html
+ fi
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.c
+ fi
+}