summaryrefslogtreecommitdiff
path: root/ffmpeg
diff options
context:
space:
mode:
Diffstat (limited to 'ffmpeg')
-rw-r--r--ffmpeg/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/ffmpeg/APKBUILD b/ffmpeg/APKBUILD
index 442a50f..a40c64b 100644
--- a/ffmpeg/APKBUILD
+++ b/ffmpeg/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ffmpeg
pkgver=4.2.2
-pkgrel=0
+pkgrel=1
pkgdesc="Complete and free Internet live audio and video broadcasting solution for Linux/Unix"
url="https://ffmpeg.org/"
arch="all"
@@ -106,11 +106,12 @@ esac
build() {
local _dbg="--disable-debug"
- local _asm=""
+ local _arch_opts=""
[ -n "$DEBUG" ] && _dbg="--enable-debug"
case "$CARCH" in
- x86) _asm="--disable-asm" ;;
+ x86) _arch_opts="--disable-asm" ;;
+ aarch64|arm*) _arch_opts="- --enable-omx --enable-omx-rpi --enable-nonfree" ;;
esac
./configure \
@@ -140,7 +141,7 @@ build() {
--enable-vaapi \
--enable-vdpau \
--enable-libopus \
- $_asm $_aom $_dbg
+ $_arch_opts $_aom $_dbg
make
${CC:-gcc} -o tools/qt-faststart $CFLAGS tools/qt-faststart.c
make doc/ffmpeg.1 doc/ffplay.1