summaryrefslogtreecommitdiff
path: root/ffmpeg/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'ffmpeg/APKBUILD')
-rw-r--r--ffmpeg/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/ffmpeg/APKBUILD b/ffmpeg/APKBUILD
index a40c64b..2c82132 100644
--- a/ffmpeg/APKBUILD
+++ b/ffmpeg/APKBUILD
@@ -98,20 +98,25 @@ source="https://ffmpeg.org/releases/ffmpeg-$pkgver.tar.xz
# add support for AV1 codec for all archies except armhf and armv7
# as aom is not available on them
_aom="";
+_omx="";
case "$CARCH" in
x86|x86_64|aarch64|ppc64le|s390x )
_aom="--enable-libaom"; makedepends="$makedepends aom-dev" ;;
esac
+case "$CARCH" in
+ aarch64|arm* )
+ _omx="--enable-omx --enable-omx-rpi"; makedepends="$makedepends libomxil-bellagio-dev" ;;
+esac
+
build() {
local _dbg="--disable-debug"
local _arch_opts=""
[ -n "$DEBUG" ] && _dbg="--enable-debug"
case "$CARCH" in
- x86) _arch_opts="--disable-asm" ;;
- aarch64|arm*) _arch_opts="- --enable-omx --enable-omx-rpi --enable-nonfree" ;;
+ x86) _asm="--disable-asm" ;;
esac
./configure \
@@ -141,7 +146,7 @@ build() {
--enable-vaapi \
--enable-vdpau \
--enable-libopus \
- $_arch_opts $_aom $_dbg
+ $_asm $_aom $_omx $_dbg
make
${CC:-gcc} -o tools/qt-faststart $CFLAGS tools/qt-faststart.c
make doc/ffmpeg.1 doc/ffplay.1