summaryrefslogtreecommitdiff
path: root/ffmpeg-rpi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'ffmpeg-rpi/APKBUILD')
-rw-r--r--ffmpeg-rpi/APKBUILD107
1 files changed, 0 insertions, 107 deletions
diff --git a/ffmpeg-rpi/APKBUILD b/ffmpeg-rpi/APKBUILD
deleted file mode 100644
index 0591a29..0000000
--- a/ffmpeg-rpi/APKBUILD
+++ /dev/null
@@ -1,107 +0,0 @@
-# Maintainer: Karel Kočí <cynerd@email.cz>
-pkgname=ffmpeg-rpi
-pkgver=4.2.2
-pkgrel=8
-pkgdesc="Complete and free Internet live audio and video broadcasting solution for Linux/Unix - Raspberry Pi"
-url="https://ffmpeg.org/"
-arch="armhf armv7 aarch64"
-license="GPL-2.0-or-later AND LGPL-2.1-or-later"
-options="!check"
-subpackages="$pkgname-dev $pkgname-doc"
-provides="ffmpeg ffmpeg-libs"
-provides_dev="ffmpeg-dev"
-provides_doc="ffmpeg-doc"
-makedepends="
- alsa-lib-dev
- coreutils
- bzip2-dev
- gnutls-dev
- imlib2-dev
- lame-dev
- libass-dev
- libssh-dev
- libtheora-dev
- libvorbis-dev
- libvpx-dev
- libxfixes-dev
- opus-dev
- perl-dev
- raspberrypi-dev
- sdl2-dev
- v4l-utils-dev
- x264-dev
- x265-dev
- xvidcore-dev
- yasm
- zlib-dev
- "
-source="https://ffmpeg.org/releases/ffmpeg-$pkgver.tar.xz
- fix-libversion.patch"
-
-# add support for AV1 codec for all archies except armhf and armv7
-# as aom is not available on them
-_aom="";
-
-case "$CARCH" in
- aarch64)
- _aom="--enable-libaom"; makedepends="$makedepends aom-dev" ;;
-esac
-
-unpack() {
- default_unpack
- mv "ffmpeg-$pkgver" "$builddir"
-}
-
-build() {
- local _dbg="--disable-debug"
- [ -n "$DEBUG" ] && _dbg="--enable-debug"
-
- ./configure \
- --prefix=/usr \
- --target-os=linux \
- --enable-avresample \
- --enable-avfilter \
- --enable-gnutls \
- --enable-gpl \
- --enable-libass \
- --enable-libmp3lame \
- --enable-libvorbis \
- --enable-libvpx \
- --enable-libxvid \
- --enable-libx264 \
- --enable-libx265 \
- --enable-libtheora \
- --enable-libv4l2 \
- --enable-postproc \
- --enable-pic \
- --enable-pthreads \
- --enable-shared \
- --enable-libxcb \
- --enable-libssh \
- --enable-libopus \
- --disable-stripping \
- --disable-static \
- --disable-librtmp \
- --disable-vaapi \
- --disable-vdpau \
- --enable-omx \
- --enable-omx-rpi \
- --enable-mmal \
- --extra-cflags="-I/opt/vc/include -I/opt/vc/include/IL" \
- --extra-ldflags="-L/opt/vc/lib" \
- --extra-libs="-lbcm_host -lvcos -lvchiq_arm -lmmal -lmmal_core -lmmal_util -lvcsm" \
- $_aom $_dbg
- make
- cat libavcodec/libavcodec.version
- cat */*.version
- ${CC:-gcc} -o tools/qt-faststart $CFLAGS tools/qt-faststart.c
- make doc/ffmpeg.1 doc/ffplay.1
-}
-
-package() {
- make DESTDIR="$pkgdir" install install-man
- install -D -m755 tools/qt-faststart "$pkgdir/usr/bin/qt-faststart"
-}
-
-sha512sums="381cd6732fa699eb89000621cf34256920596ed1f9de3c2194dbad35fdf2165269eb7d3a147a0eb75dc18fbb6d601382b5801750e09fc63547766842f84208e3 ffmpeg-4.2.2.tar.xz
-9125910cc402a36b92c0c92a13c1b435065ae3e18fbb4dc651d37b8dffbd69a57e706fa9efc009e989d9b8236fac5fca189ffeeb8a12f9d956d40b1cdda372c8 fix-libversion.patch"