summaryrefslogtreecommitdiff
path: root/shellrc
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-09-03 08:17:46 +0200
committerKarel Kočí <cynerd@email.cz>2018-09-03 08:17:46 +0200
commitdad08f69c493f83a1b87ab5ec721fbe90d5adc15 (patch)
tree9c2a9b322693e181fa283c50cef800c478a7779c /shellrc
parent64d694a43c113500b90adf657d8942c4dd09c306 (diff)
downloadalpine-personal-pkgs-dad08f69c493f83a1b87ab5ec721fbe90d5adc15.tar.gz
alpine-personal-pkgs-dad08f69c493f83a1b87ab5ec721fbe90d5adc15.tar.bz2
alpine-personal-pkgs-dad08f69c493f83a1b87ab5ec721fbe90d5adc15.zip
Reorder repository
Diffstat (limited to 'shellrc')
-rw-r--r--shellrc/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/shellrc/APKBUILD b/shellrc/APKBUILD
new file mode 100644
index 0000000..32112c9
--- /dev/null
+++ b/shellrc/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Karel Kočí <cynerd@email.cz>
+# Maintainer: Karel Kočí <cynerd@email.cz>
+pkgname=shellrc
+pkgver=0.5.2
+pkgrel=0
+pkgdesc="Shell initialization files"
+url="https://git.cynerd.cz/shellrc/"
+arch="noarch"
+license="GPL-3.0+"
+subpackages="$pkgname-zsh $pkgname-bash"
+source="https://git.cynerd.cz/shellrc/snapshot/$pkgname-$pkgver.tar.gz"
+options="!check"
+
+package() {
+ "$builddir/install" --prefix "$pkgdir"
+}
+
+zsh() {
+ depends="zsh"
+ "$builddir/install" --prefix "$subpkgdir" --zsh --no-base
+}
+
+bash() {
+ depends="bash"
+ "$builddir/install" --prefix "$subpkgdir" --bash --no-base
+}
+
+sha512sums="6680c6e83a1ace52e0e6d40f94c3673fdbee0ce4ea20652e05242bad510c753f296a67f356814e998d245205d906f5847b8b6c22eaa369956ce597308e63a811 shellrc-0.5.2.tar.gz"