summaryrefslogtreecommitdiff
path: root/personal
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-08-12 18:53:18 +0200
committerKarel Kočí <cynerd@email.cz>2018-08-12 18:53:18 +0200
commitddbe6363ddf3a75068ab77b352e14ec1eae58738 (patch)
tree508d864e266c8f8e180718863a21158c7176dc9f /personal
parent9c58d43c0cb6326b04d984dd23b78db5d4c1fea2 (diff)
downloadalpine-personal-pkgs-ddbe6363ddf3a75068ab77b352e14ec1eae58738.tar.gz
alpine-personal-pkgs-ddbe6363ddf3a75068ab77b352e14ec1eae58738.tar.bz2
alpine-personal-pkgs-ddbe6363ddf3a75068ab77b352e14ec1eae58738.zip
Add wireguard-virt and make multirepository git
Diffstat (limited to 'personal')
-rw-r--r--personal/shellrc/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/personal/shellrc/APKBUILD b/personal/shellrc/APKBUILD
new file mode 100644
index 0000000..32112c9
--- /dev/null
+++ b/personal/shellrc/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Karel Kočí <cynerd@email.cz>
+# Maintainer: Karel Kočí <cynerd@email.cz>
+pkgname=shellrc
+pkgver=0.5.2
+pkgrel=0
+pkgdesc="Shell initialization files"
+url="https://git.cynerd.cz/shellrc/"
+arch="noarch"
+license="GPL-3.0+"
+subpackages="$pkgname-zsh $pkgname-bash"
+source="https://git.cynerd.cz/shellrc/snapshot/$pkgname-$pkgver.tar.gz"
+options="!check"
+
+package() {
+ "$builddir/install" --prefix "$pkgdir"
+}
+
+zsh() {
+ depends="zsh"
+ "$builddir/install" --prefix "$subpkgdir" --zsh --no-base
+}
+
+bash() {
+ depends="bash"
+ "$builddir/install" --prefix "$subpkgdir" --bash --no-base
+}
+
+sha512sums="6680c6e83a1ace52e0e6d40f94c3673fdbee0ce4ea20652e05242bad510c753f296a67f356814e998d245205d906f5847b8b6c22eaa369956ce597308e63a811 shellrc-0.5.2.tar.gz"