summaryrefslogtreecommitdiff
path: root/ffmpeg-rpi/ffmpeg-99.1008-dav1d-enable-av1.patch
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-01-29 23:39:59 +0100
committerKarel Kočí <cynerd@email.cz>2020-01-29 23:39:59 +0100
commit53b7a6e4a180ddf1baaed8c3393229eb4ffa86f7 (patch)
tree201a5b8d076425f68733c9dc00d664dd1cc5c838 /ffmpeg-rpi/ffmpeg-99.1008-dav1d-enable-av1.patch
parent75148c3d7a641d491cff015ed9cee3b13a59165a (diff)
downloadalpine-personal-pkgs-53b7a6e4a180ddf1baaed8c3393229eb4ffa86f7.tar.gz
alpine-personal-pkgs-53b7a6e4a180ddf1baaed8c3393229eb4ffa86f7.tar.bz2
alpine-personal-pkgs-53b7a6e4a180ddf1baaed8c3393229eb4ffa86f7.zip
ffmpeg-rpi: try to port from LibreELEC
Diffstat (limited to 'ffmpeg-rpi/ffmpeg-99.1008-dav1d-enable-av1.patch')
-rw-r--r--ffmpeg-rpi/ffmpeg-99.1008-dav1d-enable-av1.patch407
1 files changed, 407 insertions, 0 deletions
diff --git a/ffmpeg-rpi/ffmpeg-99.1008-dav1d-enable-av1.patch b/ffmpeg-rpi/ffmpeg-99.1008-dav1d-enable-av1.patch
new file mode 100644
index 0000000..213c7c1
--- /dev/null
+++ b/ffmpeg-rpi/ffmpeg-99.1008-dav1d-enable-av1.patch
@@ -0,0 +1,407 @@
+diff -Nur a/configure b/configure
+--- a/configure 2018-11-23 12:03:27.041287929 -0500
++++ b/configure 2018-11-23 12:08:52.945786916 -0500
+@@ -226,6 +226,7 @@
+ --enable-libcelt enable CELT decoding via libcelt [no]
+ --enable-libcdio enable audio CD grabbing with libcdio [no]
+ --enable-libcodec2 enable codec2 en/decoding using libcodec2 [no]
++ --enable-libdav1d enable AV1 decoding via libdav1d [no]
+ --enable-libdc1394 enable IIDC-1394 grabbing using libdc1394
+ and libraw1394 [no]
+ --enable-libfdk-aac enable AAC de/encoding via libfdk-aac [no]
+@@ -1700,6 +1701,7 @@
+ libcaca
+ libcelt
+ libcodec2
++ libdav1d
+ libdc1394
+ libdrm
+ libflite
+@@ -3062,6 +3064,7 @@
+ libcelt_decoder_deps="libcelt"
+ libcodec2_decoder_deps="libcodec2"
+ libcodec2_encoder_deps="libcodec2"
++libdav1d_decoder_deps="libdav1d"
+ libfdk_aac_decoder_deps="libfdk_aac"
+ libfdk_aac_encoder_deps="libfdk_aac"
+ libfdk_aac_encoder_select="audio_frame_queue"
+@@ -6003,6 +6006,7 @@
+ die "ERROR: libcelt must be installed and version must be >= 0.11.0."; }
+ enabled libcaca && require_pkg_config libcaca caca caca.h caca_create_canvas
+ enabled libcodec2 && require libcodec2 codec2/codec2.h codec2_create -lcodec2
++enabled libdav1d && require_pkg_config libdav1d "dav1d >= 0.0.1" "dav1d/dav1d.h" dav1d_version
+ enabled libdc1394 && require_pkg_config libdc1394 libdc1394-2 dc1394/dc1394.h dc1394_new
+ enabled libdrm && require_pkg_config libdrm libdrm xf86drm.h drmGetVersion
+ enabled libfdk_aac && { check_pkg_config libfdk_aac fdk-aac "fdk-aac/aacenc_lib.h" aacEncOpen ||
+diff -Nur a/libavcodec/allcodecs.c b/libavcodec/allcodecs.c
+--- a/libavcodec/allcodecs.c 2018-11-23 12:03:27.041287929 -0500
++++ b/libavcodec/allcodecs.c 2018-11-23 12:11:08.584268221 -0500
+@@ -670,6 +670,7 @@
+ extern AVCodec ff_libcelt_decoder;
+ extern AVCodec ff_libcodec2_encoder;
+ extern AVCodec ff_libcodec2_decoder;
++extern AVCodec ff_libdav1d_decoder;
+ extern AVCodec ff_libfdk_aac_encoder;
+ extern AVCodec ff_libfdk_aac_decoder;
+ extern AVCodec ff_libgsm_encoder;
+diff -Nur a/libavcodec/libdav1d.c b/libavcodec/libdav1d.c
+--- a/libavcodec/libdav1d.c 1969-12-31 19:00:00.000000000 -0500
++++ b/libavcodec/libdav1d.c 2018-11-23 12:33:35.820468086 -0500
+@@ -0,0 +1,346 @@
++/*
++ * Copyright (c) 2018 Ronald S. Bultje <rsbultje gmail com>
++ * Copyright (c) 2018 James Almer <jamrial gmail com>
++ *
++ * This file is part of FFmpeg.
++ *
++ * FFmpeg is free software; you can redistribute it and/or
++ * modify it under the terms of the GNU Lesser General Public
++ * License as published by the Free Software Foundation; either
++ * version 2.1 of the License, or (at your option) any later version.
++ *
++ * FFmpeg is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ * Lesser General Public License for more details.
++ *
++ * You should have received a copy of the GNU Lesser General Public
++ * License along with FFmpeg; if not, write to the Free Software
++ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
++ */
++
++#include <dav1d/dav1d.h>
++
++#include "libavutil/avassert.h"
++#include "libavutil/mastering_display_metadata.h"
++#include "libavutil/imgutils.h"
++#include "libavutil/opt.h"
++
++#include "avcodec.h"
++#include "decode.h"
++#include "internal.h"
++
++typedef struct Libdav1dContext {
++ AVClass *class;
++ Dav1dContext *c;
++ AVBufferPool *pool;
++ int pool_size;
++
++ Dav1dData data;
++ int tile_threads;
++ int apply_grain;
++} Libdav1dContext;
++
++static const enum AVPixelFormat pix_fmt[][3] = {
++ [DAV1D_PIXEL_LAYOUT_I400] = { AV_PIX_FMT_GRAY8, AV_PIX_FMT_GRAY10, AV_PIX_FMT_GRAY12 },
++ [DAV1D_PIXEL_LAYOUT_I420] = { AV_PIX_FMT_YUV420P, AV_PIX_FMT_YUV420P10, AV_PIX_FMT_YUV420P12 },
++ [DAV1D_PIXEL_LAYOUT_I422] = { AV_PIX_FMT_YUV422P, AV_PIX_FMT_YUV422P10, AV_PIX_FMT_YUV422P12 },
++ [DAV1D_PIXEL_LAYOUT_I444] = { AV_PIX_FMT_YUV444P, AV_PIX_FMT_YUV444P10, AV_PIX_FMT_YUV444P12 },
++};
++
++static void libdav1d_log_callback(void *opaque, const char *fmt, va_list vl)
++{
++ AVCodecContext *c = opaque;
++
++ av_vlog(c, AV_LOG_ERROR, fmt, vl);
++}
++
++static int libdav1d_picture_allocator(Dav1dPicture *p, void *cookie)
++{
++ Libdav1dContext *dav1d = cookie;
++ enum AVPixelFormat format = pix_fmt[p->p.layout][p->seq_hdr->hbd];
++ int ret, linesize[4], h = FFALIGN(p->p.h, 128);
++ uint8_t *aligned_ptr, *data[4];
++ AVBufferRef *buf;
++
++ ret = av_image_fill_arrays(data, linesize, NULL, format, FFALIGN(p->p.w, 128),
++ h, DAV1D_PICTURE_ALIGNMENT);
++ if (ret < 0)
++ return ret;
++
++ if (ret != dav1d->pool_size) {
++ av_buffer_pool_uninit(&dav1d->pool);
++ // Use twice the amount of required padding bytes for aligned_ptr below.
++ dav1d->pool = av_buffer_pool_init(ret + DAV1D_PICTURE_ALIGNMENT * 2, NULL);
++ if (!dav1d->pool) {
++ dav1d->pool_size = 0;
++ return AVERROR(ENOMEM);
++ }
++ dav1d->pool_size = ret;
++ }
++ buf = av_buffer_pool_get(dav1d->pool);
++ if (!buf)
++ return AVERROR(ENOMEM);
++
++ // libdav1d requires DAV1D_PICTURE_ALIGNMENT aligned buffers, which av_malloc()
++ // doesn't guarantee for example when AVX is disabled at configure time.
++ // Use the extra DAV1D_PICTURE_ALIGNMENT padding bytes in the buffer to align it
++ // if required.
++ aligned_ptr = (uint8_t *)FFALIGN((uintptr_t)buf->data, DAV1D_PICTURE_ALIGNMENT);
++ ret = av_image_fill_pointers(data, format, h, aligned_ptr, linesize);
++ if (ret < 0) {
++ av_buffer_unref(&buf);
++ return ret;
++ }
++
++ p->data[0] = data[0];
++ p->data[1] = data[1];
++ p->data[2] = data[2];
++ p->stride[0] = linesize[0];
++ p->stride[1] = linesize[1];
++ p->allocator_data = buf;
++
++ return 0;
++}
++
++static void libdav1d_picture_release(Dav1dPicture *p, void *cookie)
++{
++ AVBufferRef *buf = p->allocator_data;
++
++ av_buffer_unref(&buf);
++}
++
++static av_cold int libdav1d_init(AVCodecContext *c)
++{
++ Libdav1dContext *dav1d = c->priv_data;
++ Dav1dSettings s;
++ int res;
++
++ av_log(c, AV_LOG_INFO, "libdav1d %s\n", dav1d_version());
++
++ dav1d_default_settings(&s);
++ s.logger.cookie = c;
++ s.logger.callback = libdav1d_log_callback;
++ s.allocator.cookie = dav1d;
++ s.allocator.alloc_picture_callback = libdav1d_picture_allocator;
++ s.allocator.release_picture_callback = libdav1d_picture_release;
++ s.n_tile_threads = dav1d->tile_threads;
++ s.apply_grain = dav1d->apply_grain;
++ s.n_frame_threads = FFMIN(c->thread_count ? c->thread_count : av_cpu_count(), DAV1D_MAX_FRAME_THREADS);
++
++ res = dav1d_open(&dav1d->c, &s);
++ if (res < 0)
++ return AVERROR(ENOMEM);
++
++ return 0;
++}
++
++static void libdav1d_flush(AVCodecContext *c)
++{
++ Libdav1dContext *dav1d = c->priv_data;
++
++ dav1d_data_unref(&dav1d->data);
++ dav1d_flush(dav1d->c);
++}
++
++static void libdav1d_data_free(const uint8_t *data, void *opaque) {
++ AVBufferRef *buf = opaque;
++
++ av_buffer_unref(&buf);
++}
++
++static int libdav1d_receive_frame(AVCodecContext *c, AVFrame *frame)
++{
++ Libdav1dContext *dav1d = c->priv_data;
++ Dav1dData *data = &dav1d->data;
++ Dav1dPicture pic = { 0 }, *p = &pic;
++ int res;
++
++ if (!data->sz) {
++ AVPacket pkt = { 0 };
++
++ res = ff_decode_get_packet(c, &pkt);
++ if (res < 0 && res != AVERROR_EOF)
++ return res;
++
++ if (pkt.size) {
++ res = dav1d_data_wrap(data, pkt.data, pkt.size, libdav1d_data_free, pkt.buf);
++ if (res < 0) {
++ av_packet_unref(&pkt);
++ return res;
++ }
++
++ data->m.timestamp = pkt.pts;
++ data->m.offset = pkt.pos;
++ data->m.duration = pkt.duration;
++
++ pkt.buf = NULL;
++ av_packet_unref(&pkt);
++ }
++ }
++
++ res = dav1d_send_data(dav1d->c, data);
++ if (res < 0) {
++ if (res == AVERROR(EINVAL))
++ res = AVERROR_INVALIDDATA;
++ if (res != AVERROR(EAGAIN))
++ return res;
++ }
++
++ res = dav1d_get_picture(dav1d->c, p);
++ if (res < 0) {
++ if (res == AVERROR(EINVAL))
++ res = AVERROR_INVALIDDATA;
++ else if (res == AVERROR(EAGAIN) && c->internal->draining)
++ res = AVERROR_EOF;
++
++ return res;
++ }
++
++ av_assert0(p->data[0] != NULL);
++
++ // This requires the custom allocator above
++ frame->buf[0] = av_buffer_ref(p->allocator_data);
++ if (!frame->buf[0]) {
++ dav1d_picture_unref(p);
++ return AVERROR(ENOMEM);
++ }
++
++ frame->data[0] = p->data[0];
++ frame->data[1] = p->data[1];
++ frame->data[2] = p->data[2];
++ frame->linesize[0] = p->stride[0];
++ frame->linesize[1] = p->stride[1];
++ frame->linesize[2] = p->stride[1];
++
++ c->profile = p->seq_hdr->profile;
++ frame->format = c->pix_fmt = pix_fmt[p->p.layout][p->seq_hdr->hbd];
++ frame->width = p->p.w;
++ frame->height = p->p.h;
++ if (c->width != p->p.w || c->height != p->p.h) {
++ res = ff_set_dimensions(c, p->p.w, p->p.h);
++ if (res < 0)
++ goto fail;
++ }
++
++ switch (p->seq_hdr->chr) {
++ case DAV1D_CHR_VERTICAL:
++ frame->chroma_location = c->chroma_sample_location = AVCHROMA_LOC_LEFT;
++ break;
++ case DAV1D_CHR_COLOCATED:
++ frame->chroma_location = c->chroma_sample_location = AVCHROMA_LOC_TOPLEFT;
++ break;
++ }
++ frame->colorspace = c->colorspace = (enum AVColorSpace) p->seq_hdr->mtrx;
++ frame->color_primaries = c->color_primaries = (enum AVColorPrimaries) p->seq_hdr->pri;
++ frame->color_trc = c->color_trc = (enum AVColorTransferCharacteristic) p->seq_hdr->trc;
++ frame->color_range = c->color_range = p->seq_hdr->color_range ? AVCOL_RANGE_JPEG : AVCOL_RANGE_MPEG;
++
++ // match timestamps and packet size
++ frame->pts = frame->best_effort_timestamp = p->m.timestamp;
++#if FF_API_PKT_PTS
++FF_DISABLE_DEPRECATION_WARNINGS
++ frame->pkt_pts = p->m.timestamp;
++FF_ENABLE_DEPRECATION_WARNINGS
++#endif
++ frame->pkt_dts = p->m.timestamp;
++ frame->pkt_pos = p->m.offset;
++ frame->pkt_size = p->m.size;
++ frame->pkt_duration = p->m.duration;
++ frame->key_frame = p->frame_hdr->frame_type == DAV1D_FRAME_TYPE_KEY;
++
++ switch (p->frame_hdr->frame_type) {
++ case DAV1D_FRAME_TYPE_KEY:
++ case DAV1D_FRAME_TYPE_INTRA:
++ frame->pict_type = AV_PICTURE_TYPE_I;
++ break;
++ case DAV1D_FRAME_TYPE_INTER:
++ frame->pict_type = AV_PICTURE_TYPE_P;
++ break;
++ case DAV1D_FRAME_TYPE_SWITCH:
++ frame->pict_type = AV_PICTURE_TYPE_SP;
++ break;
++ default:
++ res = AVERROR_INVALIDDATA;
++ goto fail;
++ }
++
++ if (p->mastering_display) {
++ AVMasteringDisplayMetadata *mastering = av_mastering_display_metadata_create_side_data(frame);
++ if (!mastering) {
++ res = AVERROR(ENOMEM);
++ goto fail;
++ }
++
++ for (int i = 0; i < 3; i++) {
++ mastering->display_primaries[i][0] = av_make_q(p->mastering_display->primaries[i][0], 1 << 16);
++ mastering->display_primaries[i][1] = av_make_q(p->mastering_display->primaries[i][1], 1 << 16);
++ }
++ mastering->white_point[0] = av_make_q(p->mastering_display->white_point[0], 1 << 16);
++ mastering->white_point[1] = av_make_q(p->mastering_display->white_point[1], 1 << 16);
++
++ mastering->max_luminance = av_make_q(p->mastering_display->max_luminance, 1 << 8);
++ mastering->min_luminance = av_make_q(p->mastering_display->min_luminance, 1 << 14);
++
++ mastering->has_primaries = 1;
++ mastering->has_luminance = 1;
++ }
++ if (p->content_light) {
++ AVContentLightMetadata *light = av_content_light_metadata_create_side_data(frame);
++ if (!light) {
++ res = AVERROR(ENOMEM);
++ goto fail;
++ }
++ light->MaxCLL = p->content_light->max_content_light_level;
++ light->MaxFALL = p->content_light->max_frame_average_light_level;
++ }
++
++ res = 0;
++fail:
++ dav1d_picture_unref(p);
++ if (res < 0)
++ av_frame_unref(frame);
++ return res;
++}
++
++static av_cold int libdav1d_close(AVCodecContext *c)
++{
++ Libdav1dContext *dav1d = c->priv_data;
++
++ av_buffer_pool_uninit(&dav1d->pool);
++ dav1d_data_unref(&dav1d->data);
++ dav1d_close(&dav1d->c);
++
++ return 0;
++}
++
++#define OFFSET(x) offsetof(Libdav1dContext, x)
++#define VD AV_OPT_FLAG_VIDEO_PARAM | AV_OPT_FLAG_DECODING_PARAM
++static const AVOption libdav1d_options[] = {
++ { "tilethreads", "Tile threads", OFFSET(tile_threads), AV_OPT_TYPE_INT, { .i64 = 1 }, 1, DAV1D_MAX_TILE_THREADS, VD },
++ { "filmgrain", "Apply Film Grain", OFFSET(apply_grain), AV_OPT_TYPE_BOOL, { .i64 = 1 }, 0, 1, VD },
++ { NULL }
++};
++
++static const AVClass libdav1d_class = {
++ .class_name = "libdav1d decoder",
++ .item_name = av_default_item_name,
++ .option = libdav1d_options,
++ .version = LIBAVUTIL_VERSION_INT,
++};
++
++AVCodec ff_libdav1d_decoder = {
++ .name = "libdav1d",
++ .long_name = NULL_IF_CONFIG_SMALL("dav1d AV1 decoder by VideoLAN"),
++ .type = AVMEDIA_TYPE_VIDEO,
++ .id = AV_CODEC_ID_AV1,
++ .priv_data_size = sizeof(Libdav1dContext),
++ .init = libdav1d_init,
++ .close = libdav1d_close,
++ .flush = libdav1d_flush,
++ .receive_frame = libdav1d_receive_frame,
++ .capabilities = AV_CODEC_CAP_DELAY | AV_CODEC_CAP_AUTO_THREADS,
++ .caps_internal = FF_CODEC_CAP_INIT_THREADSAFE | FF_CODEC_CAP_SETS_PKT_DTS,
++ .priv_class = &libdav1d_class,
++ .wrapper_name = "libdav1d",
++};
+diff -Nur a/libavcodec/Makefile b/libavcodec/Makefile
+--- a/libavcodec/Makefile 2018-11-23 12:03:27.041287929 -0500
++++ b/libavcodec/Makefile 2018-11-23 12:10:28.676717867 -0500
+@@ -954,6 +954,7 @@
+ OBJS-$(CONFIG_LIBCELT_DECODER) += libcelt_dec.o
+ OBJS-$(CONFIG_LIBCODEC2_DECODER) += libcodec2.o codec2utils.o
+ OBJS-$(CONFIG_LIBCODEC2_ENCODER) += libcodec2.o codec2utils.o
++OBJS-$(CONFIG_LIBDAV1D_DECODER) += libdav1d.o
+ OBJS-$(CONFIG_LIBFDK_AAC_DECODER) += libfdk-aacdec.o
+ OBJS-$(CONFIG_LIBFDK_AAC_ENCODER) += libfdk-aacenc.o
+ OBJS-$(CONFIG_LIBGSM_DECODER) += libgsmdec.o