summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-04-15 13:52:44 +0200
committerKarel Kočí <cynerd@email.cz>2020-04-15 13:52:44 +0200
commitb8d35c952384e37cf9923031cf16b937d482cd98 (patch)
treec202a0802dc270891aaf1481e893b752689b7169
parent2d41d5aa14264e4cb5ddd3ea9aa065999a6233c8 (diff)
downloadalpine-personal-pkgs-b8d35c952384e37cf9923031cf16b937d482cd98.tar.gz
alpine-personal-pkgs-b8d35c952384e37cf9923031cf16b937d482cd98.tar.bz2
alpine-personal-pkgs-b8d35c952384e37cf9923031cf16b937d482cd98.zip
spotifyd: fix spawn and better cache directory
-rw-r--r--spotifyd/APKBUILD2
-rw-r--r--spotifyd/spotifyd.conf2
-rwxr-xr-xspotifyd/spotifyd.init3
3 files changed, 3 insertions, 4 deletions
diff --git a/spotifyd/APKBUILD b/spotifyd/APKBUILD
index 21c1bd5..1e23dcd 100644
--- a/spotifyd/APKBUILD
+++ b/spotifyd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Karel Kočí <cynerd@email.cz>
pkgname=spotifyd
pkgver=0.2.24
-pkgrel=2
+pkgrel=3
pkgdesc="A spotify daemon"
url="https://github.com/Spotifyd/spotifyd"
arch="all !aarch64 !armv7"
diff --git a/spotifyd/spotifyd.conf b/spotifyd/spotifyd.conf
index 4f7c179..82c0220 100644
--- a/spotifyd/spotifyd.conf
+++ b/spotifyd/spotifyd.conf
@@ -31,7 +31,7 @@ bitrate = 320
#
# Note: The file path does not get expanded. Environment variables and
# shell placeholders like $HOME or ~ don't work!
-cache_path = /var/cache/spotifyd
+cache_path = /var/lib/spotify/cache
# If set to true, audio data does NOT get cached.
no_audio_cache = true
diff --git a/spotifyd/spotifyd.init b/spotifyd/spotifyd.init
index 7f9d316..e540408 100755
--- a/spotifyd/spotifyd.init
+++ b/spotifyd/spotifyd.init
@@ -4,9 +4,8 @@ name="Spotifyd"
description="Spotify player daemon"
command=/usr/bin/spotifyd
-pidfile=/var/run/spotifyd.pid
-command_args="--pid '$pidfile'"
command_user="spotify:spotify"
+supervisor=supervise-daemon
depend() {
need net