summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-01-29 23:50:30 +0100
committerKarel Kočí <cynerd@email.cz>2020-01-29 23:51:24 +0100
commit8dceffbc6c0c85ab9da170383706099e7c416e6d (patch)
treeea1dcd3a27aeababa70ecb59869268a4f2d839c6
parent298db9734aed26e5a08a0b326deb4d30369ee942 (diff)
downloadalpine-personal-pkgs-8dceffbc6c0c85ab9da170383706099e7c416e6d.tar.gz
alpine-personal-pkgs-8dceffbc6c0c85ab9da170383706099e7c416e6d.tar.bz2
alpine-personal-pkgs-8dceffbc6c0c85ab9da170383706099e7c416e6d.zip
ffmpeg-rpi: another shot in fixing it
-rw-r--r--ffmpeg-rpi/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/ffmpeg-rpi/APKBUILD b/ffmpeg-rpi/APKBUILD
index 4ad0d11..266c359 100644
--- a/ffmpeg-rpi/APKBUILD
+++ b/ffmpeg-rpi/APKBUILD
@@ -37,7 +37,6 @@ makedepends="
raspberrypi-dev
"
srcver="4.0.4-Leia-18.4"
-builddir="$srcdir/FFmpeg--$srcver"
source="https://github.com/xbmc/FFmpeg/archive/$srcver.tar.gz
ffmpeg-99.1001-Call-get_format-to-fix-an-issue-with-MMAL-ren.patch
ffmpeg-99.1002-mpeg4video-Signal-unsupported-GMC-with-more-than-one.patch
@@ -52,6 +51,11 @@ source="https://github.com/xbmc/FFmpeg/archive/$srcver.tar.gz
# as aom is not available on them
_aom="";
+unpack() {
+ default_unpack
+ mv "FFmpeg-$srcver" "$builddir"
+}
+
build() {
local _dbg="--disable-debug"
[ -n "$DEBUG" ] && _dbg="--enable-debug"