summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-09-28 22:18:35 +0200
committerKarel Kočí <cynerd@email.cz>2020-09-28 22:18:35 +0200
commit6cd7bd8f87660b5d3914aefb441792c8589f7e60 (patch)
tree9828f52562b9c61018fd454ef99a7509205fb17f
parent9f07a980bfe4bf407261e64ec5d77f317e528a7e (diff)
downloadalpine-personal-pkgs-6cd7bd8f87660b5d3914aefb441792c8589f7e60.tar.gz
alpine-personal-pkgs-6cd7bd8f87660b5d3914aefb441792c8589f7e60.tar.bz2
alpine-personal-pkgs-6cd7bd8f87660b5d3914aefb441792c8589f7e60.zip
spotifyd: temporally drop
-rw-r--r--spotifyd/APKBUILD41
-rw-r--r--spotifyd/spotifyd.conf43
-rwxr-xr-xspotifyd/spotifyd.init14
-rwxr-xr-xspotifyd/spotifyd.pre-install8
4 files changed, 0 insertions, 106 deletions
diff --git a/spotifyd/APKBUILD b/spotifyd/APKBUILD
deleted file mode 100644
index 0ad67e1..0000000
--- a/spotifyd/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Karel Kočí <cynerd@email.cz>
-# Maintainer: Karel Kočí <cynerd@email.cz>
-pkgname=spotifyd
-pkgver=0.2.24.20200828
-commit=76a7940144c35af0706c61d27602a499f8736916
-pkgrel=1
-pkgdesc="A spotify daemon"
-url="https://github.com/Spotifyd/spotifyd"
-arch="all"
-license="GPLv3"
-options="!check net"
-
-makedepends="cargo alsa-lib-dev openssl-dev"
-
-source="
- spotifyd.init
- spotifyd.conf
- $pkgname-$pkgver.tar.gz::https://github.com/Spotifyd/spotifyd/archive/$commit.tar.gz
-"
-install="$pkgname.pre-install"
-
-export CARGO_HOME="$srcdir/cargo"
-
-unpack() {
- default_unpack
- mv "$pkgname-$commit" "$builddir"
-}
-
-build() {
- cargo build --release
-}
-
-package() {
- cargo install --path . --root="$pkgdir"/usr
- install -D -m 755 "$srcdir"/spotifyd.init "$pkgdir"/etc/init.d/spotifyd
- install -D -m 644 "$srcdir"/spotifyd.conf "$pkgdir"/etc/spotifyd.conf
-}
-
-sha512sums="151a01af3dd6833d0e058178e8839dd9e53ab9f43a3acd1d86200affc14b457fc00f7500f3dd69635b79a057d70325260264a5d043ac433b1ef4af355b94ad88 spotifyd.init
-37bf97478d5c9ed9bb9495efeb244c049a4c5eb7a75c19e431a29acdbca6e0e79ddd1089ffbd62c42e402063ab84cd6604bac4db1d8c98e613ca78fb35209ca3 spotifyd.conf
-6ba35a840552fe8190afb60ad0fecf134720ea97b8226f3bdb95b1ce691820acf544e7588db9b3f03d0b9671372fd6530b3cda402948324f1fb6d30615c095a4 spotifyd-0.2.24.20200828.tar.gz"
diff --git a/spotifyd/spotifyd.conf b/spotifyd/spotifyd.conf
deleted file mode 100644
index 82c0220..0000000
--- a/spotifyd/spotifyd.conf
+++ /dev/null
@@ -1,43 +0,0 @@
-# Spotifyd configuration file
-# You have to set username and password!
-# For complete documentation see: https://github.com/Spotifyd/spotifyd
-##################################################################################
-[global]
-# Your Spotify account name.
-#username = username
-
-# Your Spotify account password.
-#password = password
-
-# The name that gets displayed under the connect tab on
-# official clients. Spaces are not allowed!
-#device_name = alpinelinux-spotifyd
-
-# The alsa audio device to stream audio to. To get a
-# list of valid devices, run `aplay -L`,
-device = sysdefault
-
-# The alsa mixer used by `spotifyd`.
-mixer = Master
-
-##################################################################################
-
-# The audio bitrate. 96, 160 or 320 kbit/s
-bitrate = 320
-
-# The director used to cache audio data. This setting can save
-# a lot of bandwidth when activated, as it will avoid re-downloading
-# audio files when replaying them.
-#
-# Note: The file path does not get expanded. Environment variables and
-# shell placeholders like $HOME or ~ don't work!
-cache_path = /var/lib/spotify/cache
-
-# If set to true, audio data does NOT get cached.
-no_audio_cache = true
-
-# If set to true, enables volume normalisation between songs.
-volume_normalisation = true
-
-# The normalisation pregain that is applied for each song.
-normalisation_pregain = -10
diff --git a/spotifyd/spotifyd.init b/spotifyd/spotifyd.init
deleted file mode 100755
index 7b9d214..0000000
--- a/spotifyd/spotifyd.init
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/sbin/openrc-run
-
-name="Spotifyd"
-description="Spotify player daemon"
-
-command=/usr/bin/spotifyd
-command_args_foreground="--no-daemon"
-command_user="spotify:spotify"
-supervisor=supervise-daemon
-
-depend() {
- need net
- use logger
-}
diff --git a/spotifyd/spotifyd.pre-install b/spotifyd/spotifyd.pre-install
deleted file mode 100755
index 282e21c..0000000
--- a/spotifyd/spotifyd.pre-install
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-
-addgroup -S spotify 2>/dev/null
-adduser -S -D -h /var/lib/spotify -s /sbin/nologin -G spotify spotify 2>/dev/null
-
-adduser spotify audio 2>/dev/null
-
-exit 0